-
Notifications
You must be signed in to change notification settings - Fork 94
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gtkhash: Build thunar plugin (#4660)
**Summary** - Build Thunar plugin - Add dependency to the respective file manager for each plugin Fixes #4657 Signed-off-by: Evan Maddock <[email protected]> **Test Plan** - Install the Thunar plugin, view a file's properties, and generate a bunch of checksum hashes in the Checksums tab. - Inspect the package metadata for all plugin packages and make sure that the dependencies are correct. **Checklist** - [x] Package was built and tested against unstable - [x] This change could gainfully be listed in the weekly sync notes once merged <!-- Write an appropriate message in the Summary section, then add the "Topic: Sync Notes" label -->
- Loading branch information
Showing
8 changed files
with
90 additions
and
13 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
libgtkhash-properties-caja.so | ||
libgtkhash-properties-nemo.so | ||
libgtkhash-properties-thunar.so |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,4 +8,5 @@ libgobject-2.0.so.0 | |
libgtk-3.so.0 | ||
libnemo-extension.so.1 | ||
libnettle.so.8 | ||
libthunarx-3.so.0 | ||
libz.so.1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
From 4d04fd487ff29ac442ff8d5bf40b330cd0e274d4 Mon Sep 17 00:00:00 2001 | ||
From: xiao sheng wen <[email protected]> | ||
Date: Wed, 23 Oct 2024 15:35:54 +0100 | ||
Subject: [PATCH] msgfmt keyword should use --keyword=WORD , not use a space, | ||
--keyword WORD | ||
|
||
--- | ||
data/caja/Makefile.am | 2 +- | ||
data/caja/meson.build | 4 ++-- | ||
2 files changed, 3 insertions(+), 3 deletions(-) | ||
|
||
diff --git a/data/caja/Makefile.am b/data/caja/Makefile.am | ||
index d6eab85..ca49e0c 100644 | ||
--- a/data/caja/Makefile.am | ||
+++ b/data/caja/Makefile.am | ||
@@ -8,4 +8,4 @@ EXTRA_DIST = \ | ||
CLEANFILES = $(cajaextensions_DATA) | ||
|
||
%.caja-extension: %.caja-extension.in | ||
- $(AM_V_GEN)$(MSGFMT) --desktop --keyword Name --keyword Description --template $< -d $(top_srcdir)/po -o $@ | ||
+ $(AM_V_GEN)$(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@ | ||
diff --git a/data/caja/meson.build b/data/caja/meson.build | ||
index ce1e8a8..ad60238 100644 | ||
--- a/data/caja/meson.build | ||
+++ b/data/caja/meson.build | ||
@@ -16,7 +16,7 @@ i18n.merge_file( | ||
po_dir: po_dir, | ||
type: 'desktop', | ||
args: [ | ||
- '--keyword', 'Name', | ||
- '--keyword', 'Description', | ||
+ '--keyword=Name', | ||
+ '--keyword=Description', | ||
] | ||
) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
releases: | ||
id: 1269 | ||
rss: https://github.com/tristanheaven/gtkhash/tags.atom | ||
# No known CPE, checked 2024-12-23 | ||
security: | ||
cpe: ~ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,8 +3,8 @@ | |
<Name>gtkhash</Name> | ||
<Homepage>https://gtkhash.org/</Homepage> | ||
<Packager> | ||
<Name>Muhammad Alfi Syahrin</Name> | ||
<Email>[email protected]</Email> | ||
<Name>Evan Maddock</Name> | ||
<Email>[email protected]</Email> | ||
</Packager> | ||
<License>GPL-2.0-or-later</License> | ||
<PartOf>system.utils</PartOf> | ||
|
@@ -74,7 +74,7 @@ | |
<Description xml:lang="en">Caja extension for GtkHash</Description> | ||
<PartOf>desktop</PartOf> | ||
<RuntimeDependencies> | ||
<Dependency releaseFrom="20">gtkhash</Dependency> | ||
<Dependency releaseFrom="21">gtkhash</Dependency> | ||
</RuntimeDependencies> | ||
<Files> | ||
<Path fileType="library">/usr/lib64/caja/extensions-2.0/libgtkhash-properties-caja.so</Path> | ||
|
@@ -88,20 +88,33 @@ | |
<Description xml:lang="en">Nemo extension for GtkHash</Description> | ||
<PartOf>desktop</PartOf> | ||
<RuntimeDependencies> | ||
<Dependency releaseFrom="20">gtkhash</Dependency> | ||
<Dependency releaseFrom="21">gtkhash</Dependency> | ||
</RuntimeDependencies> | ||
<Files> | ||
<Path fileType="library">/usr/lib64/nemo/extensions-3.0/libgtkhash-properties-nemo.so</Path> | ||
<Path fileType="data">/usr/share/metainfo/org.gtkhash.nemo.metainfo.xml</Path> | ||
</Files> | ||
</Package> | ||
<Package> | ||
<Name>gtkhash-thunar-extension</Name> | ||
<Summary xml:lang="en">Thunar extension for GtkHash</Summary> | ||
<Description xml:lang="en">Thunar extension for GtkHash</Description> | ||
<PartOf>desktop</PartOf> | ||
<RuntimeDependencies> | ||
<Dependency releaseFrom="21">gtkhash</Dependency> | ||
</RuntimeDependencies> | ||
<Files> | ||
<Path fileType="library">/usr/lib64/thunarx-3/libgtkhash-properties-thunar.so</Path> | ||
<Path fileType="data">/usr/share/metainfo/org.gtkhash.thunar.metainfo.xml</Path> | ||
</Files> | ||
</Package> | ||
<History> | ||
<Update release="20"> | ||
<Date>2023-12-31</Date> | ||
<Update release="21"> | ||
<Date>2024-12-23</Date> | ||
<Version>1.5</Version> | ||
<Comment>Packaging update</Comment> | ||
<Name>Muhammad Alfi Syahrin</Name> | ||
<Email>[email protected]</Email> | ||
<Name>Evan Maddock</Name> | ||
<Email>[email protected]</Email> | ||
</Update> | ||
</History> | ||
</PISI> |