Skip to content

Commit

Permalink
gtkhash: Build thunar plugin
Browse files Browse the repository at this point in the history
**Summary**
- Build Thunar plugin
- Add dependency to the respective file manager for each plugin

Fixes #4657

Signed-off-by: Evan Maddock <[email protected]>
  • Loading branch information
EbonJaeger committed Dec 23, 2024
1 parent 7bf3c5c commit 9d549c2
Show file tree
Hide file tree
Showing 8 changed files with 90 additions and 13 deletions.
1 change: 1 addition & 0 deletions packages/g/gtkhash/abi_libs
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
libgtkhash-properties-caja.so
libgtkhash-properties-nemo.so
libgtkhash-properties-thunar.so
3 changes: 3 additions & 0 deletions packages/g/gtkhash/abi_symbols
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,6 @@ libgtkhash-properties-caja.so:caja_module_shutdown
libgtkhash-properties-nemo.so:nemo_module_initialize
libgtkhash-properties-nemo.so:nemo_module_list_types
libgtkhash-properties-nemo.so:nemo_module_shutdown
libgtkhash-properties-thunar.so:thunar_extension_initialize
libgtkhash-properties-thunar.so:thunar_extension_list_types
libgtkhash-properties-thunar.so:thunar_extension_shutdown
1 change: 1 addition & 0 deletions packages/g/gtkhash/abi_used_libs
Original file line number Diff line number Diff line change
Expand Up @@ -8,4 +8,5 @@ libgobject-2.0.so.0
libgtk-3.so.0
libnemo-extension.so.1
libnettle.so.8
libthunarx-3.so.0
libz.so.1
4 changes: 4 additions & 0 deletions packages/g/gtkhash/abi_used_symbols
Original file line number Diff line number Diff line change
Expand Up @@ -294,5 +294,9 @@ libnettle.so.8:nettle_sha3_256
libnettle.so.8:nettle_sha3_384
libnettle.so.8:nettle_sha3_512
libnettle.so.8:nettle_sha512
libthunarx-3.so.0:thunarx_file_info_get_file_info
libthunarx-3.so.0:thunarx_file_info_get_uri
libthunarx-3.so.0:thunarx_property_page_new
libthunarx-3.so.0:thunarx_property_page_provider_get_type
libz.so.1:adler32
libz.so.1:crc32
35 changes: 35 additions & 0 deletions packages/g/gtkhash/files/msgfmt.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From 4d04fd487ff29ac442ff8d5bf40b330cd0e274d4 Mon Sep 17 00:00:00 2001
From: xiao sheng wen <[email protected]>
Date: Wed, 23 Oct 2024 15:35:54 +0100
Subject: [PATCH] msgfmt keyword should use --keyword=WORD , not use a space,
--keyword WORD

---
data/caja/Makefile.am | 2 +-
data/caja/meson.build | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/data/caja/Makefile.am b/data/caja/Makefile.am
index d6eab85..ca49e0c 100644
--- a/data/caja/Makefile.am
+++ b/data/caja/Makefile.am
@@ -8,4 +8,4 @@ EXTRA_DIST = \
CLEANFILES = $(cajaextensions_DATA)

%.caja-extension: %.caja-extension.in
- $(AM_V_GEN)$(MSGFMT) --desktop --keyword Name --keyword Description --template $< -d $(top_srcdir)/po -o $@
+ $(AM_V_GEN)$(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
diff --git a/data/caja/meson.build b/data/caja/meson.build
index ce1e8a8..ad60238 100644
--- a/data/caja/meson.build
+++ b/data/caja/meson.build
@@ -16,7 +16,7 @@ i18n.merge_file(
po_dir: po_dir,
type: 'desktop',
args: [
- '--keyword', 'Name',
- '--keyword', 'Description',
+ '--keyword=Name',
+ '--keyword=Description',
]
)
6 changes: 6 additions & 0 deletions packages/g/gtkhash/monitoring.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
releases:
id: 1269
rss: https://github.com/tristanheaven/gtkhash/tags.atom
# No known CPE, checked 2024-12-23
security:
cpe: ~
24 changes: 19 additions & 5 deletions packages/g/gtkhash/package.yml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
name : gtkhash
version : '1.5'
release : 20
release : 21
source :
- https://github.com/tristanheaven/gtkhash/releases/download/v1.5/gtkhash-1.5.tar.xz : 7102a192eca3e82ed67a8252a6850440e50c1dbea7c6364bda154ec80f8ff005
homepage : https://gtkhash.org/
Expand All @@ -9,30 +9,43 @@ component :
- system.utils
- caja-extension : desktop
- nemo-extension : desktop
- thunar-extension : desktop
summary :
- A GTK+ utility for computing message digests or checksums
- caja-extension : Caja extension for GtkHash
- nemo-extension : Nemo extension for GtkHash
- thunar-extension : Thunar extension for GtkHash
description:
- A GTK+ utility for computing message digests or checksums
- caja-extension : Caja extension for GtkHash
- nemo-extension : Nemo extension for GtkHash
- thunar-extension : Thunar extension for GtkHash
builddeps :
- pkgconfig(gtk+-3.0)
- pkgconfig(libcaja-extension)
- pkgconfig(libgcrypt)
- pkgconfig(libnemo-extension)
- pkgconfig(nettle)
- pkgconfig(nss)
- pkgconfig(thunarx-3)
rundeps :
- caja-extension : gtkhash
- nemo-extension : gtkhash
- caja-extension :
- caja
- gtkhash
- nemo-extension :
- gtkhash
- nemo
- thunar-extension :
- gtkhash
- thunar
patterns :
- /*
- caja-extension : [/usr/lib64/caja, /usr/share/caja, /usr/share/metainfo/*caja*]
- nemo-extension : [/usr/lib64/nemo, /usr/share/metainfo/*nemo*]
- thunar-extension : [/usr/lib64/thunarx-3, /usr/share/metainfo/*thunar*]
setup : |
%configure \
%patch -p1 -i $pkgfiles/msgfmt.patch
%reconfigure \
--disable-blake2 \
--disable-glib-checksums \
--disable-schemas-compile \
Expand All @@ -42,7 +55,8 @@ setup : |
--enable-nemo \
--enable-nettle \
--enable-nls \
--enable-nss
--enable-nss \
--enable-thunar
build : |
%make
install : |
Expand Down
29 changes: 21 additions & 8 deletions packages/g/gtkhash/pspec_x86_64.xml
Original file line number Diff line number Diff line change
Expand Up @@ -3,8 +3,8 @@
<Name>gtkhash</Name>
<Homepage>https://gtkhash.org/</Homepage>
<Packager>
<Name>Muhammad Alfi Syahrin</Name>
<Email>[email protected]</Email>
<Name>Evan Maddock</Name>
<Email>[email protected]</Email>
</Packager>
<License>GPL-2.0-or-later</License>
<PartOf>system.utils</PartOf>
Expand Down Expand Up @@ -74,7 +74,7 @@
<Description xml:lang="en">Caja extension for GtkHash</Description>
<PartOf>desktop</PartOf>
<RuntimeDependencies>
<Dependency releaseFrom="20">gtkhash</Dependency>
<Dependency releaseFrom="21">gtkhash</Dependency>
</RuntimeDependencies>
<Files>
<Path fileType="library">/usr/lib64/caja/extensions-2.0/libgtkhash-properties-caja.so</Path>
Expand All @@ -88,20 +88,33 @@
<Description xml:lang="en">Nemo extension for GtkHash</Description>
<PartOf>desktop</PartOf>
<RuntimeDependencies>
<Dependency releaseFrom="20">gtkhash</Dependency>
<Dependency releaseFrom="21">gtkhash</Dependency>
</RuntimeDependencies>
<Files>
<Path fileType="library">/usr/lib64/nemo/extensions-3.0/libgtkhash-properties-nemo.so</Path>
<Path fileType="data">/usr/share/metainfo/org.gtkhash.nemo.metainfo.xml</Path>
</Files>
</Package>
<Package>
<Name>gtkhash-thunar-extension</Name>
<Summary xml:lang="en">Thunar extension for GtkHash</Summary>
<Description xml:lang="en">Thunar extension for GtkHash</Description>
<PartOf>desktop</PartOf>
<RuntimeDependencies>
<Dependency releaseFrom="21">gtkhash</Dependency>
</RuntimeDependencies>
<Files>
<Path fileType="library">/usr/lib64/thunarx-3/libgtkhash-properties-thunar.so</Path>
<Path fileType="data">/usr/share/metainfo/org.gtkhash.thunar.metainfo.xml</Path>
</Files>
</Package>
<History>
<Update release="20">
<Date>2023-12-31</Date>
<Update release="21">
<Date>2024-12-23</Date>
<Version>1.5</Version>
<Comment>Packaging update</Comment>
<Name>Muhammad Alfi Syahrin</Name>
<Email>[email protected]</Email>
<Name>Evan Maddock</Name>
<Email>[email protected]</Email>
</Update>
</History>
</PISI>

0 comments on commit 9d549c2

Please sign in to comment.