Skip to content

Commit

Permalink
fix: Temporarily remove xwayland scaling patch while issue with Disco…
Browse files Browse the repository at this point in the history
…rd is addressed
  • Loading branch information
KyleGospo committed Apr 20, 2024
1 parent 458ddc3 commit ff4116c
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 18 deletions.
31 changes: 15 additions & 16 deletions staging/mutter/0004-1441.patch
Original file line number Diff line number Diff line change
Expand Up @@ -1282,7 +1282,7 @@ index 094d79616..9919bd4d0 100644
+/* Supports eventfd */
+#mesondefine HAVE_EVENTFD
diff --git a/data/dbus-interfaces/org.gnome.Mutter.DisplayConfig.xml b/data/dbus-interfaces/org.gnome.Mutter.DisplayConfig.xml
index 86421b7b0..7294c57a8 100644
index 2fe8450a8..b05337d74 100644
--- a/data/dbus-interfaces/org.gnome.Mutter.DisplayConfig.xml
+++ b/data/dbus-interfaces/org.gnome.Mutter.DisplayConfig.xml
@@ -396,8 +396,8 @@
Expand Down Expand Up @@ -4559,7 +4559,7 @@ index 47c29d94a..c6c23708e 100644

/**
diff --git a/src/meson.build b/src/meson.build
index f7797ff9c..e658f98ca 100644
index 653ea0c9a..05df3bfd2 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -579,6 +579,8 @@ if have_wayland
Expand All @@ -4580,7 +4580,7 @@ index f7797ff9c..e658f98ca 100644
'wayland/meta-wayland-outputs.c',
'wayland/meta-wayland-outputs.h',
'wayland/meta-wayland-pointer.c',
@@ -1084,6 +1088,7 @@ if have_wayland
@@ -1079,6 +1083,7 @@ if have_wayland
['xdg-output', 'unstable', 'v1', ],
['xdg-shell', 'stable', ],
['xwayland-keyboard-grab', 'unstable', 'v1', ],
Expand Down Expand Up @@ -6923,16 +6923,16 @@ index 59360e30a..3f64758a5 100644

#include "backends/meta-backend-private.h"
#include "clutter/clutter.h"
@@ -58,6 +59,8 @@
#include "wayland/meta-wayland-private.h"
@@ -59,6 +60,8 @@
#include "common/meta-cogl-drm-formats.h"
#include "common/meta-drm-format-helpers.h"
#include "compositor/meta-multi-texture-format-private.h"
+#include "wayland/meta-drm-timeline.h"
+#include "wayland/meta-wayland-linux-drm-syncobj.h"

#ifdef HAVE_NATIVE_BACKEND
#include "backends/native/meta-drm-buffer-gbm.h"
@@ -711,12 +714,43 @@
@@ -712,12 +715,43 @@ meta_wayland_buffer_inc_use_count (MetaWaylandBuffer *buffer)
void
meta_wayland_buffer_dec_use_count (MetaWaylandBuffer *buffer)
{
Expand Down Expand Up @@ -6977,34 +6977,33 @@ index 59360e30a..3f64758a5 100644
}

gboolean
@@ -980,6 +1014,7 @@
@@ -981,6 +1015,7 @@ meta_wayland_buffer_finalize (GObject *object)

clear_tainted_scanout_onscreens (buffer);
g_clear_pointer (&buffer->tainted_scanout_onscreens, g_hash_table_unref);
+ g_clear_pointer (&buffer->release_points, g_ptr_array_unref);

g_clear_object (&buffer->egl_image.texture);
#ifdef HAVE_WAYLAND_EGLSTREAM
@@ -998,6 +1033,7 @@
@@ -999,6 +1034,7 @@ meta_wayland_buffer_finalize (GObject *object)
static void
meta_wayland_buffer_init (MetaWaylandBuffer *buffer)
{
+ buffer->release_points = g_ptr_array_new_with_free_func (g_free);
}

static void
@@ -1090,8 +1126,10 @@
@@ -1091,7 +1127,9 @@ meta_wayland_init_shm (MetaWaylandCompositor *compositor)

drm_format = shm_to_drm_format (possible_formats[i]);
format_info = meta_format_info_from_drm_format (drm_format);
- g_assert (format_info);
+
+ if (!format_info)
+ continue;
+

if (!context_supports_format (cogl_context, format_info))
continue;

diff --git a/src/wayland/meta-wayland-buffer.h b/src/wayland/meta-wayland-buffer.h
index 23aea7cb2..a0d59f51b 100644
--- a/src/wayland/meta-wayland-buffer.h
Expand Down Expand Up @@ -7872,7 +7871,7 @@ index 2b61a2fc8..e3a88c0a3 100644

struct _MetaWaylandDragDestFuncs
diff --git a/src/wayland/meta-wayland-surface.c b/src/wayland/meta-wayland-surface.c
index 0012798df..81ee47bbd 100644
index b132504d3..6dc5006b7 100644
--- a/src/wayland/meta-wayland-surface.c
+++ b/src/wayland/meta-wayland-surface.c
@@ -48,6 +48,7 @@
Expand Down Expand Up @@ -7914,15 +7913,15 @@ index 0012798df..81ee47bbd 100644
}

static void
@@ -925,6 +936,7 @@ meta_wayland_surface_commit (MetaWaylandSurface *surface)
@@ -914,6 +925,7 @@ meta_wayland_surface_commit (MetaWaylandSurface *surface)
MetaWaylandBuffer *buffer = pending->buffer;
MetaWaylandTransaction *transaction;
MetaWaylandSurface *subsurface_surface;
+ MetaWaylandSyncPoint *release_point = pending->drm_syncobj.release;

COGL_TRACE_BEGIN_SCOPED (MetaWaylandSurfaceCommit,
"Meta::WaylandSurface::commit()");
@@ -932,6 +944,9 @@ meta_wayland_surface_commit (MetaWaylandSurface *surface)
@@ -921,6 +933,9 @@ meta_wayland_surface_commit (MetaWaylandSurface *surface)
if (pending->scale > 0)
surface->committed_state.scale = pending->scale;

Expand All @@ -7932,7 +7931,7 @@ index 0012798df..81ee47bbd 100644
if (buffer)
{
g_autoptr (GError) error = NULL;
@@ -957,6 +972,9 @@ meta_wayland_surface_commit (MetaWaylandSurface *surface)
@@ -946,6 +961,9 @@ meta_wayland_surface_commit (MetaWaylandSurface *surface)

pending->texture = g_object_ref (surface->committed_state.texture);

Expand Down
4 changes: 2 additions & 2 deletions staging/mutter/mutter.spec
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@
%global _default_patch_fuzz 2

Name: mutter
Version: %{gnome_version}.xscaling.5
Version: %{gnome_version}.xscaling.6
Release: %autorelease
Summary: Window and compositing manager based on Clutter

Expand Down Expand Up @@ -47,7 +47,7 @@ Patch4: 0001-modified-3329.patch

# https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3567
# Scaling for Xwayland applications
Patch5: 0002-3567.patch
# Patch5: 0002-3567.patch

# https://gitlab.gnome.org/GNOME/mutter/-/merge_requests/3304/
# Nvidia secondary GPU copy acceleration
Expand Down

0 comments on commit ff4116c

Please sign in to comment.