-
Notifications
You must be signed in to change notification settings - Fork 6
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Add layer for F&S Embedded yocto layer
- Loading branch information
Showing
4 changed files
with
87 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
64 changes: 64 additions & 0 deletions
64
dynamic-layers/meta-fus/recipes-config/images/fus-image-slint-demos.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
DESCRIPTION = "F&S standard image with Slint Demos" | ||
LICENSE = "MIT" | ||
|
||
inherit core-image | ||
|
||
### WARNING: This image is NOT suitable for production use and is intended | ||
### to provide a way for users to reproduce the image used during | ||
### the validation process of i.MX BSP releases. | ||
|
||
## Select Image Features | ||
IMAGE_FEATURES += " \ | ||
debug-tweaks \ | ||
splash \ | ||
hwcodecs \ | ||
package-management \ | ||
" | ||
|
||
CORE_IMAGE_EXTRA_INSTALL += " \ | ||
packagegroup-fsl-gstreamer1.0 \ | ||
packagegroup-fsl-gstreamer1.0-full \ | ||
alsa-utils \ | ||
alsa-tools \ | ||
dosfstools \ | ||
evtest \ | ||
e2fsprogs-mke2fs \ | ||
fbset \ | ||
i2c-tools \ | ||
spitools \ | ||
iproute2 \ | ||
memtester \ | ||
ethtool \ | ||
mtd-utils \ | ||
mtd-utils-ubifs \ | ||
lmbench \ | ||
libgpiod \ | ||
libgpiod-tools \ | ||
fbida \ | ||
firmwared \ | ||
strace \ | ||
ltrace \ | ||
gdb \ | ||
kbd \ | ||
pciutils \ | ||
libsndfile1 \ | ||
libusb1 \ | ||
libxml2 \ | ||
bluez5 \ | ||
can-utils \ | ||
iw \ | ||
openssh \ | ||
wpa-supplicant \ | ||
hostapd \ | ||
liberation-fonts \ | ||
linux-firmware-wl12xx \ | ||
linux-firmware-wl18xx \ | ||
linux-firmware-sd8787 \ | ||
linux-firmware-sd8997 \ | ||
linux-firmware-pcie8997 \ | ||
linux-firmware-atmel-mxt \ | ||
nxp-wlan-sdk \ | ||
kernel-module-nxp89xx \ | ||
v4l-utils \ | ||
slint-demos \ | ||
" |
8 changes: 8 additions & 0 deletions
8
dynamic-layers/meta-fus/recipes-example/slint-demos/slint-demos/slint-demos.service
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
[Unit] | ||
Description=Startup script to launch Slint demo(s) on startup | ||
|
||
[Service] | ||
ExecStart=/usr/bin/energy-monitor | ||
|
||
[Install] | ||
WantedBy=multi-user.target |
13 changes: 13 additions & 0 deletions
13
dynamic-layers/meta-fus/recipes-example/slint-demos/slint-demos_%.bbappend
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
inherit systemd | ||
|
||
SYSTEMD_AUTO_ENABLE = "enable" | ||
SYSTEMD_SERVICE:${PN} = "slint-demos.service" | ||
|
||
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
SRC_URI:append = " file://slint-demos.service" | ||
FILES:${PN} += "${systemd_unitdir}/system/slint-demos.service" | ||
|
||
do_install:append() { | ||
install -d ${D}/${systemd_unitdir}/system | ||
install -m 0644 ${WORKDIR}/slint-demos.service ${D}/${systemd_unitdir}/system | ||
} |