Skip to content

Commit

Permalink
Add layer for F&S Embedded yocto layer
Browse files Browse the repository at this point in the history
  • Loading branch information
tronical committed Mar 27, 2024
1 parent ba13d69 commit d0e466f
Show file tree
Hide file tree
Showing 4 changed files with 87 additions and 0 deletions.
2 changes: 2 additions & 0 deletions conf/layer.conf
Original file line number Diff line number Diff line change
Expand Up @@ -17,4 +17,6 @@ RUST_PANIC_STRATEGY = "abort"
BBFILES_DYNAMIC += " \
st-openstlinux:${LAYERDIR}/dynamic-layers/meta-st-openstlinux/*/*/*.bb \
st-openstlinux:${LAYERDIR}/dynamic-layers/meta-st-openstlinux/*/*/*.bbappend \
fus:${LAYERDIR}/dynamic-layers/meta-fus/*/*/*.bb \
fus:${LAYERDIR}/dynamic-layers/meta-fus/*/*/*.bbappend \
"
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
DESCRIPTION = "F&S standard image with Slint Demos"
LICENSE = "MIT"

inherit core-image

### WARNING: This image is NOT suitable for production use and is intended
### to provide a way for users to reproduce the image used during
### the validation process of i.MX BSP releases.

## Select Image Features
IMAGE_FEATURES += " \
debug-tweaks \
splash \
hwcodecs \
package-management \
"

CORE_IMAGE_EXTRA_INSTALL += " \
packagegroup-fsl-gstreamer1.0 \
packagegroup-fsl-gstreamer1.0-full \
alsa-utils \
alsa-tools \
dosfstools \
evtest \
e2fsprogs-mke2fs \
fbset \
i2c-tools \
spitools \
iproute2 \
memtester \
ethtool \
mtd-utils \
mtd-utils-ubifs \
lmbench \
libgpiod \
libgpiod-tools \
fbida \
firmwared \
strace \
ltrace \
gdb \
kbd \
pciutils \
libsndfile1 \
libusb1 \
libxml2 \
bluez5 \
can-utils \
iw \
openssh \
wpa-supplicant \
hostapd \
liberation-fonts \
linux-firmware-wl12xx \
linux-firmware-wl18xx \
linux-firmware-sd8787 \
linux-firmware-sd8997 \
linux-firmware-pcie8997 \
linux-firmware-atmel-mxt \
nxp-wlan-sdk \
kernel-module-nxp89xx \
v4l-utils \
slint-demos \
"
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
[Unit]
Description=Startup script to launch Slint demo(s) on startup

[Service]
ExecStart=/usr/bin/energy-monitor

[Install]
WantedBy=multi-user.target
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
inherit systemd

SYSTEMD_AUTO_ENABLE = "enable"
SYSTEMD_SERVICE:${PN} = "slint-demos.service"

FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI:append = " file://slint-demos.service"
FILES:${PN} += "${systemd_unitdir}/system/slint-demos.service"

do_install:append() {
install -d ${D}/${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/slint-demos.service ${D}/${systemd_unitdir}/system
}

0 comments on commit d0e466f

Please sign in to comment.