-
Notifications
You must be signed in to change notification settings - Fork 121
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
fix: do not build unneeded utilities and man for SELinux libraries
Utilities end up on rootfs increasing size and binary count Fixes #1067 Signed-off-by: Dmitry Sharshakov <[email protected]>
- Loading branch information
Showing
3 changed files
with
35 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
diff --git a/Makefile b/Makefile | ||
index 5b5d03e2..5744d7a4 100644 | ||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -4,26 +4,21 @@ export DISABLE_CIL | ||
|
||
all: | ||
$(MAKE) -C src | ||
- $(MAKE) -C utils | ||
|
||
install: | ||
$(MAKE) -C include install | ||
$(MAKE) -C src install | ||
- $(MAKE) -C utils install | ||
- $(MAKE) -C man install | ||
|
||
relabel: | ||
$(MAKE) -C src relabel | ||
|
||
clean: | ||
$(MAKE) -C src clean | ||
- $(MAKE) -C utils clean | ||
$(MAKE) -C tests clean | ||
|
||
indent: | ||
$(MAKE) -C src $@ | ||
$(MAKE) -C include $@ | ||
- $(MAKE) -C utils $@ | ||
|
||
test: | ||
$(MAKE) -C tests test |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters