Skip to content

Commit

Permalink
Merge version 3.0.0-2+rpi1 and 3.1.0-3 to produce 3.1.0-3+rpi1
Browse files Browse the repository at this point in the history
  • Loading branch information
Raspbian automatic forward porter committed Dec 24, 2023
2 parents 8e3675e + 095ab59 commit 4af38a7
Show file tree
Hide file tree
Showing 130 changed files with 7,315 additions and 5,452 deletions.
23 changes: 12 additions & 11 deletions .github/workflows/run-tests.yml
Original file line number Diff line number Diff line change
Expand Up @@ -17,7 +17,7 @@ jobs:
strategy:
fail-fast: false
matrix:
compiler:
compiler:
- { name: g++-7, cc: gcc-7, cxx: g++-7, distro: ubuntu-20.04 }
- { name: g++-8, cc: gcc-8, cxx: g++-8, distro: ubuntu-20.04 }
- { name: g++-9, cc: gcc-9, cxx: g++-9, distro: ubuntu-latest }
Expand All @@ -33,7 +33,7 @@ jobs:
# - { name: clang-15, cc: clang-15, cxx: clang++-15, distro: ubuntu-latest }

runs-on: ${{ matrix.compiler.distro }}

steps:
- uses: actions/[email protected]
with:
Expand All @@ -44,7 +44,7 @@ jobs:
env:
CC: ${{ matrix.compiler.cc }}
CXX: ${{ matrix.compiler.cxx }}
run: mkdir build && cd build && cmake -DCMAKE_CXX_FLAGS="-Werror" ..
run: mkdir build && cd build && cmake -DCMAKE_CXX_FLAGS="-Werror" -DBUILD_EXECUTABLE=ON ..
- name: Build
run: |
echo "Build with $(nproc) thread(s)"
Expand Down Expand Up @@ -107,14 +107,13 @@ jobs:
- arch: riscv64
distro: ubuntu22.04
compiler: { name: g++-12, cc: gcc-12, cxx: g++-12 }

steps:
- uses: actions/[email protected]
with:
submodules: 'recursive'
- uses: uraimo/[email protected]
name: Build in non-x86 container
continue-on-error: ${{ contains(fromJson('["ppc64le", "s390x", "riscv64"]'), matrix.arch) || contains(fromJson('["clang-14"]'), matrix.compiler.name) }}
id: build
with:
arch: ${{ matrix.arch }}
Expand Down Expand Up @@ -150,10 +149,12 @@ jobs:
run: |
cd /volk
cd build
cmake -DCMAKE_CXX_FLAGS="-Werror" ..
cmake -DCMAKE_CXX_FLAGS="-Werror" -DBUILD_EXECUTABLE=ON ..
echo "Build with $(nproc) thread(s)"
make -j$(nproc)
./cpu_features/list_cpu_features
if [ -f ./cpu_features/list_cpu_features ]; then
./cpu_features/list_cpu_features
fi
./apps/volk-config-info --alignment
./apps/volk-config-info --avail-machines
./apps/volk-config-info --all-machines
Expand All @@ -173,7 +174,7 @@ jobs:
- name: dependencies
run: sudo apt install python3-mako liborc-dev
- name: configure
run: mkdir build && cd build && cmake -DENABLE_STATIC_LIBS=True ..
run: mkdir build && cd build && cmake -DENABLE_STATIC_LIBS=True -DBUILD_EXECUTABLE=ON ..
- name: build
run: cmake --build build -j$(nproc)
- name: Print info
Expand Down Expand Up @@ -206,7 +207,7 @@ jobs:

# build-windows-msys2:
# name: Build on windows-latest using MinGW and MSYS2

# runs-on: windows-latest
# steps:
# - uses: msys2/setup-msys2@v2
Expand All @@ -231,7 +232,7 @@ jobs:
# - name: Build
# shell: msys2 {0}
# run: cd build && make -j$(nproc)
# - name: Test
# - name: Test
# shell: msys2 {0}
# run: |
# cd build
Expand All @@ -248,7 +249,7 @@ jobs:
- name: dependencies
run: pip3 install mako
- name: configure
run: mkdir build && cd build && cmake ..
run: mkdir build && cd build && cmake -DBUILD_EXECUTABLE=ON ..
- name: build
run: cmake --build build --config Debug -j3
- name: Print info
Expand Down
2 changes: 1 addition & 1 deletion .lastrelease
Original file line number Diff line number Diff line change
@@ -1 +1 @@
v3.0.0
v3.1.0
28 changes: 10 additions & 18 deletions CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
#
# Copyright 2011-2020 Free Software Foundation, Inc.
# Copyright 2023 Magnus Lundmark <[email protected]>
#
# This file is part of VOLK
#
Expand Down Expand Up @@ -75,23 +76,14 @@ message(STATUS "Build type set to ${CMAKE_BUILD_TYPE}.")
########################################################################

set(VERSION_INFO_MAJOR_VERSION 3)
set(VERSION_INFO_MINOR_VERSION 0)
set(VERSION_INFO_MINOR_VERSION 1)
set(VERSION_INFO_MAINT_VERSION 0)
include(VolkVersion) #setup version info

macro(set_version_str VAR)
set(IN_VER ${VERSION_INFO_${VAR}_VERSION})
string(LENGTH "${IN_VER}" VER_LEN)
if(${VER_LEN} EQUAL 1)
set(VOLK_VERSION_${VAR} "0${IN_VER}")
else()
set(VOLK_VERSION_${VAR} "${IN_VER}")
endif()
endmacro()

set_version_str(MAJOR)
set_version_str(MINOR)
set_version_str(MAINT)
math(EXPR VOLK_VERSION_DECIMAL
"${VERSION_INFO_MAJOR_VERSION} * 10000
+ ${VERSION_INFO_MINOR_VERSION} * 100
+ ${VERSION_INFO_MAINT_VERSION}")

configure_file(
${CMAKE_SOURCE_DIR}/include/volk/volk_version.h.in
Expand Down Expand Up @@ -120,10 +112,8 @@ endif(MSVC)
########################################################################

# cpu_features - sensible defaults, user settable option
message(STATUS "Building Volk for ${CMAKE_SYSTEM_NAME} on ${CMAKE_SYSTEM_PROCESSOR}")
if((CMAKE_SYSTEM_PROCESSOR MATCHES
"(^mips)|(^arm)|(^aarch64)|(x86_64)|(AMD64|amd64)|(^i.86$)|(^powerpc)|(^ppc)")
AND (NOT CMAKE_SYSTEM_NAME MATCHES "kFreeBSD"))
if(CMAKE_SYSTEM_PROCESSOR MATCHES
"(^mips)|(^arm)|(^aarch64)|(x86_64)|(AMD64|amd64)|(^i.86$)|(^powerpc)|(^ppc)|(^riscv)")
option(VOLK_CPU_FEATURES "Volk uses cpu_features" ON)
else()
option(VOLK_CPU_FEATURES "Volk uses cpu_features" OFF)
Expand All @@ -146,6 +136,7 @@ if (VOLK_CPU_FEATURES)
FORCE)
set(BUILD_SHARED_LIBS_SAVED "${BUILD_SHARED_LIBS}")
set(BUILD_SHARED_LIBS OFF)
set(ENABLE_INSTALL OFF)
add_subdirectory(cpu_features)
set(BUILD_SHARED_LIBS "${BUILD_SHARED_LIBS_SAVED}")
endif()
Expand Down Expand Up @@ -250,6 +241,7 @@ install(FILES
${CMAKE_SOURCE_DIR}/include/volk/saturation_arithmetic.h
${CMAKE_SOURCE_DIR}/include/volk/volk_avx_intrinsics.h
${CMAKE_SOURCE_DIR}/include/volk/volk_avx2_intrinsics.h
${CMAKE_SOURCE_DIR}/include/volk/volk_avx2_fma_intrinsics.h
${CMAKE_SOURCE_DIR}/include/volk/volk_sse_intrinsics.h
${CMAKE_SOURCE_DIR}/include/volk/volk_sse3_intrinsics.h
${CMAKE_SOURCE_DIR}/include/volk/volk_neon_intrinsics.h
Expand Down
12 changes: 3 additions & 9 deletions apps/volk_option_helpers.cc
Original file line number Diff line number Diff line change
Expand Up @@ -188,6 +188,7 @@ void option_list::parse(int argc, char** argv)
} catch (std::exception& exc) {
throw std::exception();
};
break;
case STRING:
std::cout << this_option->printval << std::endl;
break;
Expand Down Expand Up @@ -225,15 +226,8 @@ void option_list::help()
help_line += this_option->shortform + " [ " + this_option->longform + " ]";
}

switch (help_line.size() / 8) {
case 0:
help_line += "\t";
case 1:
help_line += "\t";
case 2:
help_line += "\t";
case 3:
help_line += "\t";
while (help_line.size() < 32) {
help_line += " ";
}
help_line += this_option->msg;
std::cout << help_line << std::endl;
Expand Down
1 change: 0 additions & 1 deletion appveyor.yml
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,6 @@
#
# SPDX-License-Identifier: LGPL-3.0-or-later
#
clone_depth: 1
image: Visual Studio 2019
cache:
- packages -> appveyor.yml
Expand Down
4 changes: 2 additions & 2 deletions cmake/Modules/VolkBuildTypes.cmake
Original file line number Diff line number Diff line change
Expand Up @@ -187,9 +187,9 @@ endif(NOT WIN32)
# NOTE: This is not defined on Windows systems.
########################################################################
if(NOT WIN32)
SET(CMAKE_CXX_FLAGS_ASAN "-Wall -Wextra -g -O2 -fsanitize=address -fno-omit-frame-pointer" CACHE STRING
SET(CMAKE_CXX_FLAGS_ASAN "-Wall -Wextra -g -O2 -fsanitize=address -fsanitize=undefined -fno-omit-frame-pointer" CACHE STRING
"Flags used by the C++ compiler during Address Sanitized builds." FORCE)
SET(CMAKE_C_FLAGS_ASAN "-Wall -Wextra -g -O2 -fsanitize=address -fno-omit-frame-pointer" CACHE STRING
SET(CMAKE_C_FLAGS_ASAN "-Wall -Wextra -g -O2 -fsanitize=address -fsanitize=undefined -fno-omit-frame-pointer" CACHE STRING
"Flags used by the C compiler during Address Sanitized builds." FORCE)
MARK_AS_ADVANCED(
CMAKE_CXX_FLAGS_ASAN
Expand Down
36 changes: 32 additions & 4 deletions debian/changelog
Original file line number Diff line number Diff line change
@@ -1,12 +1,40 @@
volk (3.0.0-2+rpi1) trixie-staging; urgency=medium
volk (3.1.0-3+rpi1) trixie-staging; urgency=medium

[changes brought forward from 1.1-1+rpi1 by Peter Michael Green <[email protected]> at Sun, 20 Sep 2015 20:30:19 +0000]
* Disable neon.

[changes introduced in 2.1.0-2+rpi1 by Peter Michael Green]
* Add bulid-depends-indep on texlive-latex-extra.

-- Raspbian forward porter <[email protected]> Wed, 20 Sep 2023 14:03:25 +0000
-- Raspbian forward porter <[email protected]> Sun, 24 Dec 2023 13:11:22 +0000

volk (3.1.0-3) unstable; urgency=medium

* add powerpc to cpu-features dependency

-- A. Maitland Bottoms <[email protected]> Sat, 16 Dec 2023 09:31:28 -0500

volk (3.1.0-2) unstable; urgency=medium

* Avoid ORC on x32, led to test failures
* include argilo-volk/all-i386-patches
* update available cpu-features architecture list
* Express version information in decimal
* add debian/upstream/metadata
* clean __pycahe__ (Closes: #1048046)

-- A. Maitland Bottoms <[email protected]> Fri, 15 Dec 2023 17:57:14 -0500

volk (3.1.0-1) experimental; urgency=medium

* New upstream release
Improved CMake build
Better tests
New kernel API (old API still available)
New and Updated kernels
* Upload to experimental for soversion bump

-- A. Maitland Bottoms <[email protected]> Tue, 05 Dec 2023 18:12:20 -0500

volk (3.0.0-2) unstable; urgency=medium

Expand Down Expand Up @@ -495,12 +523,12 @@ volk (1.0.1-1) unstable; urgency=low
All build types now use -Wall.

* QA and Testing

The documentation around the --update option to volk_profile now makes it
clear that the option will only profile kernels without entries in
volk_profile. The signature of run_volk_tests with expanded args changed
signed types to unsigned types to reflect the actual input.

The remaining changes are all non-functional changes to address issues
from Coverity.

Expand Down
22 changes: 11 additions & 11 deletions debian/control
Original file line number Diff line number Diff line change
Expand Up @@ -5,18 +5,18 @@ Maintainer: A. Maitland Bottoms <[email protected]>
Build-Depends: cmake,
debhelper-compat (= 13),
dh-python,
liborc-0.4-dev,
libcpu-features-dev [amd64 arm64 armel armhf i386 mips64el mipsel powerpc ppc64 ppc64el x32],
python3-dev,
python3-mako
libcpu-features-dev [amd64 arm64 armel armhf i386 mips64el ppc64 ppc64el riscv64 s390x powerpc x32],
liborc-0.4-dev [!x32],
python3-dev,
python3-mako
Build-Depends-Indep: doxygen, graphviz, texlive-latex-extra,
Standards-Version: 4.6.2
Rules-Requires-Root: no
Homepage: https://libvolk.org
Vcs-Browser: https://salsa.debian.org/bottoms/pkg-volk
Vcs-Git: https://salsa.debian.org/bottoms/pkg-volk.git

Package: libvolk3.0
Package: libvolk3.1
Section: libs
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Expand All @@ -33,9 +33,9 @@ Description: vector optimized functions
Package: libvolk-dev
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends: libvolk3.0 (=${binary:Version}), ${misc:Depends}
Breaks: libvolk2-dev, libvolk1.0-dev, libvolk1-dev
Replaces: libvolk2-dev, libvolk1.0-dev, libvolk1-dev
Depends: libvolk3.1 (=${binary:Version}), ${misc:Depends}
Breaks: libvolk1-dev, libvolk1.0-dev, libvolk2-dev
Replaces: libvolk1-dev, libvolk1.0-dev, libvolk2-dev
Suggests: libvolk-doc
Multi-Arch: same
Description: vector optimized function headers
Expand All @@ -51,12 +51,12 @@ Package: libvolk-bin
Section: libs
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends: libvolk3.0 (=${binary:Version}),
Depends: libvolk3.1 (=${binary:Version}),
${misc:Depends},
${python3:Depends},
${shlibs:Depends}
Breaks: libvolk2-bin, libvolk1-bin, libvolk1.0-bin
Replaces: libvolk2-bin, libvolk1-bin, libvolk1.0-bin
Breaks: libvolk1-bin, libvolk1.0-bin, libvolk2-bin
Replaces: libvolk1-bin, libvolk1.0-bin, libvolk2-bin
Description: vector optimized runtime tools
Vector-Optimized Library of Kernels is designed to help applications
work with the processor's SIMD instruction sets. These are very
Expand Down
File renamed without changes.
File renamed without changes.
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From f9aed341bcf68cf68248e82c6ea883d937a9ab7e Mon Sep 17 00:00:00 2001
From: Clayton Smith <[email protected]>
Date: Fri, 8 Dec 2023 12:25:56 -0500
Subject: [PATCH 1/6] Allow for rounding error in float-to-int conversions

Signed-off-by: Clayton Smith <[email protected]>
---
lib/kernel_tests.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/lib/kernel_tests.h b/lib/kernel_tests.h
index 5ef3324..0f59de1 100644
--- a/lib/kernel_tests.h
+++ b/lib/kernel_tests.h
@@ -121,10 +121,10 @@ std::vector<volk_test_case_t> init_test_list(volk_test_params_t test_params)
QA(VOLK_INIT_TEST(volk_32fc_x2_multiply_conjugate_32fc, test_params))
QA(VOLK_INIT_TEST(volk_32fc_x2_divide_32fc, test_params))
QA(VOLK_INIT_TEST(volk_32fc_conjugate_32fc, test_params))
- QA(VOLK_INIT_TEST(volk_32f_s32f_convert_16i, test_params))
- QA(VOLK_INIT_TEST(volk_32f_s32f_convert_32i, test_params))
+ QA(VOLK_INIT_TEST(volk_32f_s32f_convert_16i, test_params.make_tol(1)))
+ QA(VOLK_INIT_TEST(volk_32f_s32f_convert_32i, test_params.make_tol(1)))
QA(VOLK_INIT_TEST(volk_32f_convert_64f, test_params))
- QA(VOLK_INIT_TEST(volk_32f_s32f_convert_8i, test_params))
+ QA(VOLK_INIT_TEST(volk_32f_s32f_convert_8i, test_params.make_tol(1)))
QA(VOLK_INIT_TEST(volk_32fc_convert_16ic, test_params))
QA(VOLK_INIT_TEST(volk_32fc_s32f_power_spectrum_32f, test_params.make_tol(2e-6)))
QA(VOLK_INIT_TEST(volk_32fc_x2_square_dist_32f, test_params))
--
2.39.2

44 changes: 0 additions & 44 deletions debian/patches/0001-ci-Remove-license-check.patch

This file was deleted.

Loading

0 comments on commit 4af38a7

Please sign in to comment.