-
Notifications
You must be signed in to change notification settings - Fork 43
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Daniel Golle <[email protected]>
- Loading branch information
Showing
2 changed files
with
75 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=gdk-pixbuf | ||
PKG_VERSION:=2.42.9 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/$(basename $(PKG_VERSION)) | ||
PKG_HASH:=28f7958e7bf29a32d4e963556d241d0a41a6786582ff6a5ad11665e0347fc962 | ||
|
||
PKG_MAINTAINER:=Daniel Golle <[email protected]> | ||
PKG_LICENSE:=LGPL-2.1-or-later | ||
PKG_LICENSE_FILES:=COPYING | ||
PKG_CPE_ID:=cpe:/a:gnome:gdk-pixbuf | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include $(INCLUDE_DIR)/meson.mk | ||
|
||
MESON_ARGS += \ | ||
-Dgtk_doc=false \ | ||
-Dinstalled_tests=false \ | ||
-Dman=false \ | ||
-Dtests=false | ||
|
||
define Package/libgdk-pixbuf | ||
SECTION:=video-frameworks | ||
CATEGORY:=Video | ||
SUBMENU:=Frameworks and Toolkits | ||
DEPENDS:=+giflib +libpng +libtiff +libjpeg +shared-mime-info | ||
TITLE:=GdkPixbuf: Image loading library | ||
URL:=http://www.gtk.org/ | ||
endef | ||
|
||
define Package/libgdk-pixbuf/description | ||
GdkPixbuf is a library that loads image data in various formats and stores it as linear buffers in memory. | ||
endef | ||
|
||
define Build/InstallDev | ||
$(INSTALL_DIR) $(1)/usr/include/gdk-pixbuf-2.0/gdk-pixbuf | ||
$(CP) \ | ||
$(PKG_INSTALL_DIR)/usr/include/gdk-pixbuf-2.0/gdk-pixbuf/*.h \ | ||
$(1)/usr/include/gdk-pixbuf-2.0/gdk-pixbuf/ | ||
|
||
$(INSTALL_DIR) $(1)/usr/lib | ||
$(CP) \ | ||
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,a} \ | ||
$(1)/usr/lib/ | ||
|
||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig | ||
$(INSTALL_DATA) \ | ||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \ | ||
$(1)/usr/lib/pkgconfig | ||
endef | ||
|
||
define Package/libgdk-pixbuf/install | ||
$(INSTALL_DIR) $(1)/usr/lib | ||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/ | ||
|
||
$(INSTALL_DIR) $(1)/usr/bin | ||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/lib/ | ||
endef | ||
|
||
$(eval $(call HostBuild)) | ||
$(eval $(call BuildPackage,libgdk-pixbuf)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/meson.build | ||
+++ b/meson.build | ||
@@ -378,7 +378,7 @@ endif | ||
|
||
# Documentation | ||
build_docs = get_option('gtk_doc') or get_option('docs') | ||
-subdir('docs') | ||
+# subdir('docs') | ||
|
||
if not meson.is_cross_build() | ||
meson.add_install_script('build-aux/post-install.py', |