Skip to content

Commit

Permalink
ndppd: bump to 0.2.5.43
Browse files Browse the repository at this point in the history
ndppd 0.2.5 is too old and lacks many features.
ndppd 0.2.5.43 means commit eb81b8f, 43 commits after 0.2.5.
DanielAdolfsson/ndppd@0.2.5...eb81b8f

This is what SUSE has done for SLE (SUSE Linux Enterprise), and this
version has been tested for many years, so stability should not be a
problem.
https://packagehub.suse.com/packages/ndppd/
https://build.opensuse.org/package/show/network/ndppd
https://src.opensuse.org/pool/ndppd

Signed-off-by: 谢致邦 (XIE Zhibang) <[email protected]>
  • Loading branch information
Red54 committed Oct 28, 2024
1 parent 0ff4ab0 commit f240d33
Show file tree
Hide file tree
Showing 4 changed files with 18 additions and 29 deletions.
12 changes: 6 additions & 6 deletions ndppd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,17 +8,17 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=ndppd
PKG_VERSION:=0.2.5
PKG_RELEASE:=2
PKG_VERSION:=0.2.5.43
PKG_RELEASE:=1

# Latest release
PKG_SOURCE_URL:=https://codeload.github.com/DanielAdolfsson/ndppd/tar.gz/$(PKG_VERSION)?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=ee934167f8357f0bd0015e201a77fbe4d028c59e89dc98113805c6855e1c3992
PKG_SOURCE_URL:=https://api.opensuse.org/public/source/network/ndppd/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=2a153959e7d56967c733adb36379bb56bc8b78df60daef2f0aacaa9153398d1b
PKG_LICENSE:=GPL-3.0-or-later

# Development snapshot
#PKG_SOURCE_URL=git://github.com/Tuhox/ndppd.git
#PKG_SOURCE_URL=git://github.com/DanielAdolfsson/ndppd.git
#PKG_SOURCE_VERSION=master
#PKG_SOURCE_SUBDIR=$(PKG_NAME)-$(PKG_VERSION)

Expand Down
2 changes: 1 addition & 1 deletion ndppd/patches/0001-Version-bump.patch
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ index 57ba829..3e11221 100644
#define NDPPD_NS_END }

-#define NDPPD_VERSION "0.2.4"
+#define NDPPD_VERSION "0.2.5"
+#define NDPPD_VERSION "0.2.5.43"

#include <assert.h>

20 changes: 8 additions & 12 deletions ndppd/patches/0002-Fixes-strerror_r-GNU-XSI.patch
Original file line number Diff line number Diff line change
Expand Up @@ -9,22 +9,21 @@ Subject: [PATCH 2/3] Fixes strerror_r GNU/XSI issue #40.
src/logger.h | 3 +++
2 files changed, 15 insertions(+), 1 deletions(-)

diff --git a/src/logger.cc b/src/logger.cc
index 6ddbea9..6ccb2a0 100644
--- a/src/logger.cc
+++ b/src/logger.cc
@@ -84,6 +84,6 @@ std::string logger::err()
{
char buf[2048];
@@ -89,7 +89,7 @@ std::string logger::err()
return "Unknown error";
return buf;
#else
- return strerror_r(errno, buf, sizeof(buf));
+ return strerror_r_wrapper(strerror_r(errno, buf, sizeof(buf)), buf);
#endif
}

logger logger::error()
@@ -221,4 +221,16 @@
@@ -228,4 +228,16 @@ bool logger::verbosity(const std::string
return false;
}

+// XSI-compliant: int
+std::string logger::strerror_r_wrapper(int, char* s)
+{
Expand All @@ -38,11 +37,9 @@ index 6ddbea9..6ccb2a0 100644
+}
+
NDPPD_NS_END
diff --git a/src/logger.h b/src/logger.h
index 7d3d7db..0446595 100644
--- a/src/logger.h
+++ b/src/logger.h
@@ -91,6 +91,9 @@ class logger {
@@ -91,6 +91,9 @@ private:

static int _max_pri;

Expand All @@ -52,4 +49,3 @@ index 7d3d7db..0446595 100644

};


13 changes: 3 additions & 10 deletions ndppd/patches/0003-fix-poll-header.patch
Original file line number Diff line number Diff line change
Expand Up @@ -11,8 +11,6 @@ Subject: [PATCH 3/3] Fixes a compile warning when building with musl: #warning
src/rule.h | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/iface.cc b/src/iface.cc
index f569d3c..7cbb57f 100644
--- a/src/iface.cc
+++ b/src/iface.cc
@@ -30,7 +30,7 @@
Expand All @@ -24,8 +22,6 @@ index f569d3c..7cbb57f 100644

#include <linux/filter.h>

diff --git a/src/iface.h b/src/iface.h
index 9db59ab..df7ff35 100644
--- a/src/iface.h
+++ b/src/iface.h
@@ -20,7 +20,7 @@
Expand All @@ -37,8 +33,6 @@ index 9db59ab..df7ff35 100644
#include <net/ethernet.h>

#include "ndppd.h"
diff --git a/src/proxy.h b/src/proxy.h
index 8141b2a..9299d9a 100644
--- a/src/proxy.h
+++ b/src/proxy.h
@@ -19,7 +19,7 @@
Expand All @@ -50,15 +44,14 @@ index 8141b2a..9299d9a 100644

#include "ndppd.h"

diff --git a/src/rule.h b/src/rule.h
index 0c2f79a..23086e6 100644
--- a/src/rule.h
+++ b/src/rule.h
@@ -20,6 +20,6 @@
@@ -20,7 +20,7 @@
#include <map>
#include <list>

-#include <sys/poll.h>
+#include <poll.h>

#include "ndppd.h"

0 comments on commit f240d33

Please sign in to comment.