Skip to content

Commit

Permalink
treewide: remove AUTORELEASE
Browse files Browse the repository at this point in the history
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used. Since commit 2584b0cecae ("CI: deprecate $(AUTORELEASE) via
comments"), this is even announced by the CI

The following temporary change was made to the core:

    diff --git a/rules.mk b/rules.mk
    index 57d7995d4fa8..f16367de87a8 100644
    --- a/rules.mk
    +++ b/rules.mk
    @@ -429,7 +429,7 @@ endef
     abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

     COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
    -AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
    +AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

     all:
     FORCE: ;

And this command used to fix affected packages:

    ./scripts/feeds install -a routing
    for i in $(cd feeds/routing; git grep -l 'PKG_RELEASE:=.*AUTORELEASE' | \
                                  sed 's^.*/\([^/]*\)/Makefile^\1^';);
    do
      make package/${i%/Makefile}/download
    done

Signed-off-by: Sven Eckelmann <[email protected]>
  • Loading branch information
ecsv committed Feb 3, 2024
1 parent 777c115 commit 076a275
Show file tree
Hide file tree
Showing 11 changed files with 11 additions and 11 deletions.
2 changes: 1 addition & 1 deletion alfred/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=alfred
PKG_VERSION:=2022.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=4

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
Expand Down
2 changes: 1 addition & 1 deletion batctl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=batctl
PKG_VERSION:=2022.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=3

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
Expand Down
2 changes: 1 addition & 1 deletion batman-adv/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=batman-adv
PKG_VERSION:=2022.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=8

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
Expand Down
2 changes: 1 addition & 1 deletion mcproxy/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=mcproxy
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=9

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/mcproxy/mcproxy.git
Expand Down
2 changes: 1 addition & 1 deletion minimalist-pcproxy/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=minimalist-pcproxy
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=7

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/fingon/minimalist-pcproxy.git
Expand Down
2 changes: 1 addition & 1 deletion naywatch/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=naywatch
PKG_VERSION:=1
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=7

PKG_MAINTAINER:=Nick Hainke <[email protected]>
PKG_LICENSE:=GPL-2.0-only
Expand Down
2 changes: 1 addition & 1 deletion olsrd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=olsrd
PKG_SOURCE_DATE:=2022-03-18
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=3

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/OLSR/olsrd.git
Expand Down
2 changes: 1 addition & 1 deletion oonf-dlep-radio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=oonf-dlep-radio
PKG_VERSION:=0.15.1
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=30

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/OLSR/OONF.git
Expand Down
2 changes: 1 addition & 1 deletion pimbd/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=pimbd
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=4

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/Oryon/pimbd.git
Expand Down
2 changes: 1 addition & 1 deletion prince/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=prince
PKG_VERSION:=0.4
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=3

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/AdvancedNetworkingSystems/prince/archive/refs/tags/v$(PKG_VERSION).tar.gz?
Expand Down
2 changes: 1 addition & 1 deletion vis/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=vis
PKG_RELEASE:=$(AUTORELEASE)
PKG_RELEASE:=9

PKG_SOURCE_PROTO:=git
PKG_SOURCE_DATE:=2013-04-07
Expand Down

0 comments on commit 076a275

Please sign in to comment.