-
Notifications
You must be signed in to change notification settings - Fork 3.5k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Use release tarballs from Github tags, because mirror sites are still on 9.0. Add help messages for packages. Refresh patch: - 002-remove_helptags_generation.patch Signed-off-by: Ryan Keane <[email protected]>
- Loading branch information
Showing
2 changed files
with
36 additions
and
32 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,19 +8,18 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=vim | ||
PKG_VERSION:=9.0 | ||
PKG_VERSION:=9.1.0888 | ||
PKG_RELEASE:=1 | ||
VIMVER:=90 | ||
VIMVER:=91 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 | ||
PKG_SOURCE_URL:=http://ftp.vim.org/pub/vim/unix | ||
PKG_HASH:=a6456bc154999d83d0c20d968ac7ba6e7df0d02f3cb6427fb248660bacfb336e | ||
PKG_SOURCE:=v$(PKG_VERSION).tar.gz | ||
PKG_SOURCE_URL:=https://github.com/vim/vim/archive/refs/tags | ||
PKG_HASH:=8a6513a8adcd1d136a187ba39749508d61f75d309608b1213389573db259ac21 | ||
PKG_MAINTAINER:=Marko Ratkaj <[email protected]> | ||
PKG_LICENSE:=Vim | ||
PKG_LICENSE_FILES:=LICENSE | ||
PKG_CPE_ID:=cpe:/a:vim:vim | ||
|
||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(VIMVER) | ||
PKG_BUILD_PARALLEL:=1 | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
@@ -47,7 +46,6 @@ define Package/vim-full | |
CONFLICTS:=vim | ||
endef | ||
|
||
|
||
define Package/vim-fuller | ||
$(call Package/vim/Default) | ||
TITLE+= (Big) | ||
|
@@ -83,34 +81,44 @@ define Package/vim/conffiles | |
endef | ||
|
||
define Package/vim/description | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
(Tiny build) | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
|
||
This package includes tiny version of Vim. For details please visit this link: | ||
https://vimdoc.sourceforge.net/htmldoc/various.html#:ve | ||
endef | ||
|
||
define Package/vim-full/description | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
(Normal build) | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
|
||
This package includes normal version of Vim. For details please visit this link: | ||
https://vimdoc.sourceforge.net/htmldoc/various.html#:ve | ||
endef | ||
|
||
|
||
define Package/vim-fuller/description | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
(Big build) | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
|
||
This package includes huge version of Vim. For details please visit this link: | ||
https://vimdoc.sourceforge.net/htmldoc/various.html#:ve | ||
endef | ||
|
||
define Package/vim-runtime/description | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
(Runtime files) | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
|
||
This package includes runtime files for Vim. For details please visit this link: | ||
https://vimdoc.sourceforge.net/htmldoc/various.html#:ve | ||
endef | ||
|
||
define Package/vim-help/description | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
(Help files) | ||
Vim is an almost compatible version of the UNIX editor Vi. | ||
|
||
This package includes Vimdoc help files for Vim. For details please visit this link: | ||
https://vimdoc.sourceforge.net/htmldoc/various.html#:ve | ||
endef | ||
|
||
define Package/xxd/description | ||
xxd creates a hex dump of a given file or standard input, it can also convert | ||
a hex dump back to its original binary form. | ||
xxd creates a hex dump of a given file or standard input, it can also convert | ||
a hex dump back to its original binary form. | ||
endef | ||
|
||
CONFIGURE_ARGS += \ | ||
|
@@ -180,7 +188,12 @@ define Build/Compile/vim-fuller | |
endef | ||
endif | ||
|
||
|
||
define Build/Compile/vim-runtime | ||
$(MAKE) -C $(PKG_BUILD_DIR)/src DESTDIR="$(PKG_INSTALL_DIR)" installrtbase | ||
(cd $(PKG_INSTALL_DIR) && tar -cf $(PKG_BUILD_DIR)/docs.tar ./usr/share/vim/vim$(VIMVER)/doc) | ||
rm -rf $(PKG_INSTALL_DIR)/usr/share/vim/vim$(VIMVER)/doc | ||
rm -rf $(PKG_INSTALL_DIR)/usr/man | ||
endef | ||
|
||
ifneq ($(CONFIG_PACKAGE_xxd),) | ||
define Build/Compile/xxd | ||
|
@@ -189,13 +202,6 @@ define Build/Compile/xxd | |
endef | ||
endif | ||
|
||
define Build/Compile/vim-runtime | ||
$(MAKE) -C $(PKG_BUILD_DIR)/src DESTDIR="$(PKG_INSTALL_DIR)" installrtbase | ||
(cd $(PKG_INSTALL_DIR) && tar -cf $(PKG_BUILD_DIR)/docs.tar ./usr/share/vim/vim$(VIMVER)/doc) | ||
rm -rf $(PKG_INSTALL_DIR)/usr/share/vim/vim$(VIMVER)/doc | ||
rm -rf $(PKG_INSTALL_DIR)/usr/man | ||
endef | ||
|
||
define Build/Compile | ||
$(call Build/Compile/vim) | ||
$(call Build/Compile/vim-full) | ||
|
@@ -229,8 +235,6 @@ define Package/vim-fuller/install | |
$(INSTALL_CONF) ./files/vimrc.full $(1)/usr/share/vim/vimrc | ||
endef | ||
|
||
|
||
|
||
define Package/vim-runtime/install | ||
$(CP) $(PKG_INSTALL_DIR)/* $(1) | ||
rm -rf $(1)/usr/share/vim/vim$(VIMVER)/doc | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,10 @@ | ||
--- a/runtime/doc/Makefile | ||
+++ b/runtime/doc/Makefile | ||
@@ -345,7 +345,6 @@ all: tags vim.man evim.man vimdiff.man v | ||
@@ -24,7 +24,6 @@ all: tags vim.man evim.man vimdiff.man v | ||
# Use Vim to generate the tags file. Can only be used when Vim has been | ||
# compiled and installed. Supports multiple languages. | ||
# compiled. Supports multiple languages. | ||
vimtags: $(DOCS) | ||
- @$(VIMEXE) --clean -esX -V1 -u doctags.vim | ||
- @$(VIMPROG) --clean -esX -V1 -u doctags.vim | ||
|
||
# Use "doctags" to generate the tags file. Only works for English! | ||
tags: doctags $(DOCS) |