-
Notifications
You must be signed in to change notification settings - Fork 2
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #7 from Sash0k/main
[feature] Add spec & instruction for ALT Linux rpm build
- Loading branch information
Showing
3 changed files
with
137 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
## Как собрать rpm пакет локально, на примере спецификации для ALT Linux (P11) | ||
|
||
#### Подготовка окружения для сборки | ||
* `# apt-get install rpm-build` | ||
* `$ mkdir -p ~/RPM/SPECS && mkdir -p ~/RPM/SOURCES` | ||
* `$ cd ~/RPM/SOURCES && wget https://github.com/keygenqt/aurora-toolbox/archive/refs/tags/0.0.9.tar.gz` | ||
* Скопировать файл `aurora-toolbox.spec` в `~/RPM/SPECS` и перейти туда | ||
|
||
#### Сборка rpm | ||
* `$ rpmbuild -bb aurora-toolbox.spec` | ||
* При необходимости доустановить зависимости, необходимые для сборки | ||
* Пакет соберется под ахритектуру вашей машины | ||
* Собранный rpm-пакет будет находиться в `~/RPM/RPMS` | ||
|
||
#### Установка | ||
* `# rpm -iv aurora-toolbox-0.0.9-alt1.x86_64.rpm` | ||
* При необходимости доустановить зависимости, необходимые для работы приложения |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,69 @@ | ||
%define fullname com.keygenqt.aurora-toolbox | ||
|
||
Name: aurora-toolbox | ||
Version: 0.0.9 | ||
Release: alt1 | ||
Summary: An application that provides an easy start in the Aurora OS ecosystem. | ||
|
||
License: Apache-2.0 | ||
Group: Development/Tools | ||
Url: https://github.com/keygenqt/aurora-toolbox | ||
# download from %{url}/releases/tag/%{version}.tar.gz | ||
Source: %version.tar.gz | ||
|
||
BuildRequires: meson | ||
BuildRequires: libgjs-devel | ||
BuildRequires: libgtk4-devel | ||
BuildRequires: libadwaita-devel >= 1.5 | ||
|
||
Requires: sudo | ||
Requires: gnome-extensions-app | ||
Requires: libgjs | ||
Requires: libgtk4-gir | ||
Requires: libadwaita-gir | ||
Requires: libsoup-gir | ||
|
||
%description | ||
%summary. | ||
|
||
%prep | ||
%setup | ||
|
||
%build | ||
%meson | ||
%meson_build | ||
|
||
%install | ||
%meson_install | ||
mkdir -p %{buildroot}%{_datadir}/applications | ||
mkdir -p %{buildroot}%{_datadir}/icons | ||
install ./files/package/%{fullname}.svg %{buildroot}%{_datadir}/icons/%{fullname}.svg | ||
install ./files/package/%{fullname}.desktop %{buildroot}%{_datadir}/applications/%{fullname}.desktop | ||
|
||
%post | ||
ln -sf %{_bindir}/%{fullname} %{_bindir}/%{name} | ||
|
||
%files | ||
%doc CHANGELOG.md | ||
%{_bindir}/%{fullname} | ||
%{_datadir}/%{fullname}/%{fullname}.data.gresource | ||
%{_datadir}/%{fullname}/%{fullname}.src.gresource | ||
%{_datadir}/applications/%{fullname}.desktop | ||
%{_datadir}/glib-2.0/schemas/%{fullname}.gschema.xml | ||
%{_datadir}/icons/%{fullname}.svg | ||
%{_datadir}/locale/ru/LC_MESSAGES/%{fullname}.mo | ||
|
||
%changelog | ||
* Sat Nov 02 2024 Vitaliy Zarubin 0.0.9 | ||
- Update API install psdk. (Vitaliy Zarubin) | ||
|
||
* Fri Nov 01 2024 Vitaliy Zarubin 0.0.8 | ||
- Add check version Aurora Toolbox. (Vitaliy Zarubin) | ||
- Add video about install Aurora Toolbox. (Vitaliy Zarubin) | ||
|
||
* Thu Oct 31 2024 Vitaliy Zarubin 0.0.7 | ||
- Fix button open documentation. (Vitaliy Zarubin) | ||
- Add symbolic link aurora-toolbox. (Vitaliy Zarubin) | ||
- Video install Aurora SDK. (Vitaliy Zarubin) | ||
- Video install Flutter SDK. (Vitaliy Zarubin) | ||
- Tab videos for documentation. (Vitaliy Zarubin) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
#!/bin/bash | ||
|
||
############################## | ||
## Build and create rpm package | ||
############################## | ||
|
||
#============================= | ||
check_package() | ||
{ | ||
if [ -n "`rpm -q $1`" ] | ||
then | ||
echo "Checking $1... OK" | ||
else | ||
echo "" | ||
echo "Checking $1... Not found!" | ||
echo "use: apt-get install $1" | ||
exit 1 | ||
fi | ||
} | ||
#============================= | ||
|
||
if [ -z "$1" ] | ||
then | ||
echo "usage: ./rpm.sh [version to build]" | ||
exit 1 | ||
fi | ||
|
||
NAME='aurora-toolbox' | ||
|
||
check_package sudo | ||
check_package meson | ||
check_package wget | ||
check_package rpm-build | ||
check_package libgjs-devel | ||
check_package libgtk4-devel | ||
check_package libadwaita-devel | ||
|
||
echo "" | ||
echo "Preparing..." | ||
mkdir -p ~/RPM/SOURCES && mkdir -p ~/RPM/SPECS | ||
cd ~/RPM/SOURCES && wget https://github.com/keygenqt/$NAME/archive/refs/tags/$1.tar.gz | ||
cd ~/RPM/SPECS && wget https://raw.githubusercontent.com/keygenqt/$NAME/refs/tags/$1/rpm/aurora-toolbox.spec | ||
|
||
echo "" | ||
echo "Build..." | ||
rpmbuild -bb aurora-toolbox.spec | ||
|
||
echo "" | ||
echo "Installing..." | ||
cd ~/RPM/RPMS/`arch`/ | ||
sudo rpm -i $NAME-$1*.rpm |