-
Notifications
You must be signed in to change notification settings - Fork 257
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
16 changed files
with
359 additions
and
146 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,12 +8,12 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=python-dateutil | ||
PKG_VERSION:=2.9.0.post0 | ||
PKG_VERSION:=2.9.0 | ||
PKG_RELEASE:=1 | ||
PKG_LICENSE:=BSD-2-Clause | ||
|
||
PYPI_NAME:=$(PKG_NAME) | ||
PKG_HASH:=37dd54208da7e1cd875388217d5e00ebd4179249f90fb72437e91a35459a0ad3 | ||
PKG_HASH:=78e73e19c63f5b20ffa567001531680d939dc042bf7850431877645523c66709 | ||
PKG_MAINTAINER:=Alexandru Ardelean <[email protected]> | ||
|
||
PKG_BUILD_DEPENDS:=python-setuptools-scm/host | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk | |
|
||
PKG_NAME:=adblock-fast | ||
PKG_VERSION:=1.1.2 | ||
PKG_RELEASE:=10 | ||
PKG_RELEASE:=18 | ||
PKG_MAINTAINER:=Stan Grishin <[email protected]> | ||
PKG_LICENSE:=AGPL-3.0-or-later | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
From 3da07ae96f5b40f76b75e1ccd4b20267f6a5988e Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?Jakub=20Kul=C3=ADk?= <[email protected]> | ||
Date: Wed, 28 Aug 2024 09:43:04 +0200 | ||
Subject: [PATCH] remove incorrect freeaddrinfo call | ||
|
||
--- | ||
src/net.c | 1 - | ||
1 file changed, 1 deletion(-) | ||
|
||
--- a/src/net.c | ||
+++ b/src/net.c | ||
@@ -145,7 +145,6 @@ create_socket(int domain, int proto, con | ||
if ((gerror = getaddrinfo(server, portstr, &hints, &server_res)) != 0) { | ||
if (local) | ||
freeaddrinfo(local_res); | ||
- freeaddrinfo(server_res); | ||
return -1; | ||
} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
24 changes: 24 additions & 0 deletions
24
net/microsocks/patches/001-use-a-bigger-thread-stack-by-default.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
From c81760cc3f1b6db22c7c9694efe7f3be115c2caf Mon Sep 17 00:00:00 2001 | ||
From: rofl0r <[email protected]> | ||
Date: Fri, 17 May 2024 14:38:16 +0000 | ||
Subject: [PATCH] use a bigger thread stack by default | ||
|
||
apparently newer musl versions require more stack for the TCP-based | ||
DNS resolver. | ||
|
||
closes #73 | ||
--- | ||
sockssrv.c | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
--- a/sockssrv.c | ||
+++ b/sockssrv.c | ||
@@ -47,7 +47,7 @@ | ||
#endif | ||
|
||
#ifdef PTHREAD_STACK_MIN | ||
-#define THREAD_STACK_SIZE MAX(8*1024, PTHREAD_STACK_MIN) | ||
+#define THREAD_STACK_SIZE MAX(16*1024, PTHREAD_STACK_MIN) | ||
#else | ||
#define THREAD_STACK_SIZE 64*1024 | ||
#endif |
22 changes: 22 additions & 0 deletions
22
net/microsocks/patches/002-mute-warning-about-shadow-declaration-of-bind_addr.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
From 0343813e0410b469d591bc61b9a546ee2c2c15f6 Mon Sep 17 00:00:00 2001 | ||
From: rofl0r <[email protected]> | ||
Date: Fri, 17 May 2024 14:40:11 +0000 | ||
Subject: [PATCH] mute warning about shadow declaration of bind_addr | ||
|
||
--- | ||
sockssrv.c | 4 ++-- | ||
1 file changed, 2 insertions(+), 2 deletions(-) | ||
|
||
--- a/sockssrv.c | ||
+++ b/sockssrv.c | ||
@@ -112,8 +112,8 @@ struct thread { | ||
static void dolog(const char* fmt, ...) { } | ||
#endif | ||
|
||
-static struct addrinfo* addr_choose(struct addrinfo* list, union sockaddr_union* bind_addr) { | ||
- int af = SOCKADDR_UNION_AF(bind_addr); | ||
+static struct addrinfo* addr_choose(struct addrinfo* list, union sockaddr_union* bindaddr) { | ||
+ int af = SOCKADDR_UNION_AF(bindaddr); | ||
if(af == AF_UNSPEC) return list; | ||
struct addrinfo* p; | ||
for(p=list; p; p=p->ai_next) |
Oops, something went wrong.