-
Notifications
You must be signed in to change notification settings - Fork 260
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Showing
55 changed files
with
647 additions
and
902 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- a/tayga.h | ||
+++ b/tayga.h | ||
@@ -20,6 +20,7 @@ | ||
#include <sys/stat.h> | ||
#include <sys/ioctl.h> | ||
#include <sys/socket.h> | ||
+#include <sys/uio.h> | ||
#include <netinet/in.h> | ||
#include <arpa/inet.h> | ||
#include <unistd.h> |
25 changes: 25 additions & 0 deletions
25
lang/node/patches/999-fix_building_with_system_icu_76.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
From 54299ac3a3d4e4520b8604dce43c2584092ccde2 Mon Sep 17 00:00:00 2001 | ||
From: Michael Cho <michael@michaelcho.dev> | ||
Date: Sun, 27 Oct 2024 10:08:07 -0400 | ||
Subject: [PATCH] build: fix building with system icu 76 | ||
|
||
ICU 76 decided to reduce overlinking[^1] thus `icu-i18n` will no longer | ||
add `icu-uc` when linking to shared libraries. This results in undefined | ||
symbols/references when trying to build with system ICU 76. | ||
|
||
[^1]: unicode-org/icu@199bc82 | ||
--- | ||
configure.py | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
--- a/configure.py | ||
+++ b/configure.py | ||
@@ -1876,7 +1876,7 @@ def configure_intl(o): | ||
elif with_intl == 'system-icu': | ||
# ICU from pkg-config. | ||
o['variables']['v8_enable_i18n_support'] = 1 | ||
- pkgicu = pkg_config('icu-i18n') | ||
+ pkgicu = pkg_config(['icu-i18n', 'icu-uc']) | ||
if not pkgicu[0]: | ||
error('''Could not load pkg-config data for "icu-i18n". | ||
See above errors or the README.md.''') |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,63 @@ | ||
# This is free software, licensed under the GNU General Public License v2. | ||
# See /LICENSE for more information. | ||
# | ||
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=libwacom | ||
PKG_VERSION:=2.13.0 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_URL:=https://github.com/linuxwacom/$(PKG_NAME)/releases/download/$(PKG_NAME)-$(PKG_VERSION)/ | ||
PKG_HASH:=acd18121441bbc00fc5c881fca08a33319ab814b798eac8d0be6354923f8fb08 | ||
|
||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org> | ||
PKG_LICENSE:=MIT | ||
PKG_LICENSE_FILES:=COPYING | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include $(INCLUDE_DIR)/nls.mk | ||
include $(INCLUDE_DIR)/meson.mk | ||
|
||
define Package/libwacom | ||
SECTION:=libs | ||
CATEGORY:=Libraries | ||
TITLE:=a tablet description library | ||
URL:=https://github.com/linuxwacom/libwacom | ||
DEPENDS:=+glib2 +libevdev +libgudev | ||
endef | ||
|
||
define Package/libwacom/description | ||
libwacom is a library to identify graphics tablets and their model-specific | ||
features. It provides easy access to information such as "is this a built-in | ||
on-screen tablet", "what is the size of this model", etc. | ||
|
||
The name libwacom is historical - it was originally developed for Wacom devices | ||
only but now supports any graphics tablet from any vendor. | ||
endef | ||
|
||
MESON_ARGS += \ | ||
-Ddocumentation=disabled \ | ||
-Dtests=disabled | ||
|
||
define Build/InstallDev | ||
$(INSTALL_DIR) $(1)/usr/include/libwacom-1.0/libwacom | ||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libwacom-1.0/libwacom/*.h \ | ||
$(1)/usr/include/libwacom-1.0/libwacom | ||
$(INSTALL_DIR) $(1)/usr/lib | ||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib | ||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig | ||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig | ||
endef | ||
|
||
define Package/libwacom/install | ||
$(INSTALL_DIR) $(1)/usr/bin | ||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin | ||
$(INSTALL_DIR) $(1)/usr/lib | ||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/{udev,*.so*} $(1)/usr/lib | ||
$(INSTALL_DIR) $(1)/usr/share/libwacom | ||
$(CP) $(PKG_INSTALL_DIR)/usr/share/libwacom/* $(1)/usr/share/libwacom | ||
endef | ||
|
||
$(eval $(call BuildPackage,libwacom)) |
Oops, something went wrong.