Skip to content

Commit

Permalink
Merge Official Source
Browse files Browse the repository at this point in the history
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
1715173329 committed Nov 27, 2024
2 parents 6441246 + 3140259 commit a36f680
Showing 55 changed files with 647 additions and 902 deletions.
9 changes: 6 additions & 3 deletions admin/debootstrap/Makefile
Original file line number Diff line number Diff line change
@@ -9,17 +9,20 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=debootstrap
PKG_VERSION:=1.0.128+nmu2+deb12u1
PKG_RELEASE:=1
PKG_REAL_VERSION:=1.0.128+nmu2+deb12u1
PKG_VERSION:=1.0.128.2~deb121
PKG_RELEASE:=2

PKG_SOURCE:=$(PKG_NAME)-udeb_$(PKG_VERSION)_all.udeb
PKG_SOURCE:=$(PKG_NAME)-udeb_$(PKG_REAL_VERSION)_all.udeb
PKG_SOURCE_URL:=@DEBIAN/pool/main/d/debootstrap
PKG_HASH:=4fa4ec7c144ed047c47d0d8eb9b91b56eaa9b2db2b52510777abbabf5965d268

PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=Unique
PKG_LICENSE_FILES:=debian/copyright

PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_REAL_VERSION)

UNPACK_CMD=ar -p "$(DL_DIR)/$(PKG_SOURCE)" data.tar.xz | xzcat | tar -C $(1) -xf -

include $(INCLUDE_DIR)/package.mk
6 changes: 3 additions & 3 deletions admin/openwisp-monitoring/Makefile
Original file line number Diff line number Diff line change
@@ -5,15 +5,15 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=openwisp-monitoring
PKG_VERSION:=0.2.0
PKG_RELEASE:=2
PKG_VERSION:=0.2.1
PKG_RELEASE:=1

PKG_MAINTAINER:=Federico Capoano <support@openwisp.io>
PKG_LICENSE:=GPL-3.0-or-later
PKG_LICENSE_FILES:=LICENSE

PKG_SOURCE_URL:=https://github.com/openwisp/openwrt-openwisp-monitoring.git
PKG_MIRROR_HASH:=6baad2b319cdc072a83547593b447e2c93c42fcdda386f5993c22b88ad991cdd
PKG_MIRROR_HASH:=6d74de36d84b2765c1e49b2467685e19b2e7ccf13f11ad383d7eb4ac8f57cbc9
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
PKGARCH:=all
7 changes: 4 additions & 3 deletions admin/syslog-ng/Makefile
Original file line number Diff line number Diff line change
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=syslog-ng
PKG_VERSION:=4.7.1
PKG_RELEASE:=1
PKG_RELEASE:=2

PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=LGPL-2.1-or-later GPL-2.0-or-later
@@ -35,6 +35,7 @@ define Package/syslog-ng
TITLE:=A powerful syslog daemon
URL:=https://www.syslog-ng.com/products/open-source-log-management/
DEPENDS:=+libpcre2 +glib2 +libopenssl +libpthread +librt +libdbi +libjson-c +libcurl +libuuid +SYSLOGNG_LOGROTATE:logrotate +LIBCURL_ZLIB:zlib
ALTERNATIVES:=300:/sbin/logread:/usr/libexec/logread.sh
endef

define Package/syslog-ng/description
@@ -123,8 +124,8 @@ define Package/syslog-ng/install
$(INSTALL_DATA) ./files/syslog-ng.conf $(1)/etc
touch $(1)/etc/syslog-ng.d/.keep

$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) ./files/logread $(1)/sbin
$(INSTALL_DIR) $(1)/usr/libexec
$(INSTALL_BIN) ./files/logread.sh $(1)/usr/libexec/logread.sh

$(INSTALL_DIR) $(1)/usr/share/syslog-ng/include/
$(CP) -r ./files/scl $(1)/usr/share/syslog-ng/include/
File renamed without changes.
2 changes: 1 addition & 1 deletion ipv6/tayga/Makefile
Original file line number Diff line number Diff line change
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=tayga
PKG_VERSION:=0.9.2
PKG_RELEASE:=4
PKG_RELEASE:=5

PKG_SOURCE:=tayga-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.litech.org/tayga/
10 changes: 10 additions & 0 deletions ipv6/tayga/patches/010-gcc14.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/tayga.h
+++ b/tayga.h
@@ -20,6 +20,7 @@
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <sys/socket.h>
+#include <sys/uio.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <unistd.h>
25 changes: 25 additions & 0 deletions lang/node/patches/999-fix_building_with_system_icu_76.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 54299ac3a3d4e4520b8604dce43c2584092ccde2 Mon Sep 17 00:00:00 2001
From: Michael Cho <michael@michaelcho.dev>
Date: Sun, 27 Oct 2024 10:08:07 -0400
Subject: [PATCH] build: fix building with system icu 76

ICU 76 decided to reduce overlinking[^1] thus `icu-i18n` will no longer
add `icu-uc` when linking to shared libraries. This results in undefined
symbols/references when trying to build with system ICU 76.

[^1]: unicode-org/icu@199bc82
---
configure.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--- a/configure.py
+++ b/configure.py
@@ -1876,7 +1876,7 @@ def configure_intl(o):
elif with_intl == 'system-icu':
# ICU from pkg-config.
o['variables']['v8_enable_i18n_support'] = 1
- pkgicu = pkg_config('icu-i18n')
+ pkgicu = pkg_config(['icu-i18n', 'icu-uc'])
if not pkgicu[0]:
error('''Could not load pkg-config data for "icu-i18n".
See above errors or the README.md.''')
4 changes: 2 additions & 2 deletions lang/php8/Makefile
Original file line number Diff line number Diff line change
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=php
PKG_VERSION:=8.3.12
PKG_VERSION:=8.3.14
PKG_RELEASE:=1

PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -16,7 +16,7 @@ PKG_CPE_ID:=cpe:/a:php:php

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.php.net/distributions/
PKG_HASH:=f774e28633e26fc8c5197f4dae58ec9e3ff87d1b4311cbc61ab05a7ad24bd131
PKG_HASH:=58b4cb9019bf70c0cbcdb814c7df79b9065059d14cf7dbf48d971f8e56ae9be7

PKG_BUILD_PARALLEL:=1
PKG_BUILD_FLAGS:=no-mips16
2 changes: 1 addition & 1 deletion lang/php8/patches/0022-Use-system-timezone.patch
Original file line number Diff line number Diff line change
@@ -15,7 +15,7 @@ To be used in tandem with use_embedded_timezonedb.patch and use_embedded_timezon

--- a/ext/date/php_date.c
+++ b/ext/date/php_date.c
@@ -567,6 +567,23 @@ static const char* guess_timezone(const
@@ -568,6 +568,23 @@ static const char* guess_timezone(const
} else if (*DATEG(default_timezone)) {
return DATEG(default_timezone);
}
2 changes: 1 addition & 1 deletion lang/php8/patches/0025-php-5.4.9-fixheader.patch
Original file line number Diff line number Diff line change
@@ -9,7 +9,7 @@ Make generated php_config.h constant across rebuilds.

--- a/configure.ac
+++ b/configure.ac
@@ -1507,7 +1507,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS)
@@ -1501,7 +1501,7 @@ PHP_REMOVE_USR_LIB(LDFLAGS)
EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"

2 changes: 1 addition & 1 deletion lang/php8/patches/1004-disable-phar-command.patch
Original file line number Diff line number Diff line change
@@ -11,7 +11,7 @@

--- a/configure.ac
+++ b/configure.ac
@@ -1703,13 +1703,13 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
@@ -1697,13 +1697,13 @@ CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"

6 changes: 3 additions & 3 deletions lang/python/python-setuptools-scm/Makefile
Original file line number Diff line number Diff line change
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=python-setuptools-scm
PKG_VERSION:=7.1.0
PKG_RELEASE:=2
PKG_VERSION:=8.1.0
PKG_RELEASE:=1

PYPI_NAME:=setuptools-scm
PYPI_SOURCE_NAME:=setuptools_scm
PKG_HASH:=6c508345a771aad7d56ebff0e70628bf2b0ec7573762be9960214730de278f27
PKG_HASH:=42dea1b65771cba93b7a515d65a65d8246e560768a66b9106a592c8e7f26c8a7

PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
13 changes: 6 additions & 7 deletions libs/libinput/Makefile
Original file line number Diff line number Diff line change
@@ -5,13 +5,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libinput
PKG_VERSION:=1.25.0
PKG_VERSION:=1.26.2
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://gitlab.freedesktop.org/libinput/libinput.git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
PKG_MIRROR_HASH:=e2c4a46292a17d2e037ba4eb439c135e9834041993ac641e23c71fd5ddfceb72
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.freedesktop.org/$(PKG_NAME)/$(PKG_NAME)/-/archive/$(PKG_VERSION)
PKG_HASH:=5c1c4150f217fea1db2d1fd88e2607b2f1928cfde65c34da65a9f24dcfd69464

PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=MIT
@@ -26,7 +25,7 @@ define Package/libinput
CATEGORY:=Libraries
TITLE:=a library to handle input devices
URL:=https://freedesktop.org/wiki/Software/libinput/
DEPENDS:=+libevdev +mtdev +libudev
DEPENDS:=+libevdev +mtdev +libudev +libwacom
endef

define Package/libinput/description
@@ -39,7 +38,7 @@ endef

MESON_ARGS += \
-Depoll-dir=no \
-Dlibwacom=false \
-Dlibwacom=true \
-Ddebug-gui=false \
-Dtests=false \
-Dzshcompletiondir=no
63 changes: 63 additions & 0 deletions libs/libwacom/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

include $(TOPDIR)/rules.mk

PKG_NAME:=libwacom
PKG_VERSION:=2.13.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/linuxwacom/$(PKG_NAME)/releases/download/$(PKG_NAME)-$(PKG_VERSION)/
PKG_HASH:=acd18121441bbc00fc5c881fca08a33319ab814b798eac8d0be6354923f8fb08

PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING

include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/meson.mk

define Package/libwacom
SECTION:=libs
CATEGORY:=Libraries
TITLE:=a tablet description library
URL:=https://github.com/linuxwacom/libwacom
DEPENDS:=+glib2 +libevdev +libgudev
endef

define Package/libwacom/description
libwacom is a library to identify graphics tablets and their model-specific
features. It provides easy access to information such as "is this a built-in
on-screen tablet", "what is the size of this model", etc.

The name libwacom is historical - it was originally developed for Wacom devices
only but now supports any graphics tablet from any vendor.
endef

MESON_ARGS += \
-Ddocumentation=disabled \
-Dtests=disabled

define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/libwacom-1.0/libwacom
$(CP) $(PKG_INSTALL_DIR)/usr/include/libwacom-1.0/libwacom/*.h \
$(1)/usr/include/libwacom-1.0/libwacom
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig
endef

define Package/libwacom/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/{udev,*.so*} $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/share/libwacom
$(CP) $(PKG_INSTALL_DIR)/usr/share/libwacom/* $(1)/usr/share/libwacom
endef

$(eval $(call BuildPackage,libwacom))
Loading

0 comments on commit a36f680

Please sign in to comment.