-
Notifications
You must be signed in to change notification settings - Fork 257
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
36 changed files
with
270 additions
and
398 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,17 +8,17 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=python-cryptography | ||
PKG_VERSION:=3.4.8 | ||
PKG_RELEASE:=3 | ||
PKG_VERSION:=41.0.4 | ||
PKG_RELEASE:=1 | ||
|
||
PYPI_NAME:=cryptography | ||
PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c | ||
PKG_HASH:=7febc3094125fc126a7f6fb1f420d0da639f3f32cb15c8ff0dc3997c4549f51a | ||
|
||
PKG_LICENSE:=Apache-2.0 BSD-3-Clause | ||
PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD | ||
PKG_MAINTAINER:=Jeffery To <[email protected]> | ||
|
||
PKG_BUILD_DEPENDS:=libffi/host python-cffi/host # cffi>=1.12 | ||
PKG_BUILD_DEPENDS:=libffi/host python-cffi/host python-setuptools-rust/host | ||
|
||
include ../pypi.mk | ||
include $(INCLUDE_DIR)/package.mk | ||
|
@@ -32,18 +32,18 @@ define Package/python3-cryptography | |
URL:=https://github.com/pyca/cryptography | ||
DEPENDS:= \ | ||
+libopenssl \ | ||
+libopenssl-legacy \ | ||
+python3-light \ | ||
+python3-email \ | ||
+python3-openssl \ | ||
+python3-urllib \ | ||
+python3-cffi \ | ||
+python3-six | ||
$(RUST_ARCH_DEPENDS) | ||
endef | ||
|
||
define Package/python3-cryptography/description | ||
cryptography is a package which provides cryptographic recipes and | ||
primitives to Python developers. Our goal is for it to be your "cryptographic | ||
standard library". It supports Python 2.6-2.7, Python 3.3+, and PyPy 2.6+. | ||
primitives to Python developers. Our goal is for it to be your | ||
"cryptographic standard library". | ||
endef | ||
|
||
$(eval $(call Py3Package,python3-cryptography)) | ||
|
20 changes: 0 additions & 20 deletions
20
lang/python/python-cryptography/patches/0001-Add-new-ASN1_STRING_get0_data-API.patch
This file was deleted.
Oops, something went wrong.
55 changes: 0 additions & 55 deletions
55
...on/python-cryptography/patches/0002-Add-compatibility-for-X509_STORE_set_get_issuer.patch
This file was deleted.
Oops, something went wrong.
127 changes: 0 additions & 127 deletions
127
...ython/python-cryptography/patches/0003-Add-compatibility-for-deprecated-TLS-methods.patch
This file was deleted.
Oops, something went wrong.
33 changes: 0 additions & 33 deletions
33
lang/python/python-cryptography/patches/0004-disable-rust.patch
This file was deleted.
Oops, something went wrong.
25 changes: 0 additions & 25 deletions
25
...thon-cryptography/patches/0006-Add-X509_STORE_CTX_trusted_stack-compatibility-macro.patch
This file was deleted.
Oops, something went wrong.
56 changes: 0 additions & 56 deletions
56
...ython/python-cryptography/patches/0007-Add-defines-for-totally-deprecated-functions.patch
This file was deleted.
Oops, something went wrong.
13 changes: 13 additions & 0 deletions
13
lang/python/python-cryptography/patches/001-Update-ouroboros.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
Fixes https://rustsec.org/advisories/RUSTSEC-2023-0042.html | ||
|
||
--- a/src/rust/Cargo.toml | ||
+++ b/src/rust/Cargo.toml | ||
@@ -15,7 +15,7 @@ cryptography-cffi = { path = "cryptograp | ||
cryptography-x509 = { path = "cryptography-x509" } | ||
cryptography-openssl = { path = "cryptography-openssl" } | ||
pem = "1.1" | ||
-ouroboros = "0.15" | ||
+ouroboros = "0.18" | ||
openssl = "0.10.54" | ||
openssl-sys = "0.9.88" | ||
foreign-types-shared = "0.1" |
Oops, something went wrong.