Skip to content

Commit

Permalink
[eos-packagelist] Remove ARM support
Browse files Browse the repository at this point in the history
  • Loading branch information
dalto8 committed Jun 3, 2024
1 parent 2c2aa32 commit 12b8f84
Show file tree
Hide file tree
Showing 2 changed files with 5 additions and 14 deletions.
4 changes: 1 addition & 3 deletions eos-packagelist/README.md
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
usage: `eos-packagelist [-h] [--list] [--arch ARCH] [--install] [profile ...]`
usage: `eos-packagelist [-h] [--list] [--install] [profile ...]`

The EndeavourOS package list handler gets package information from the current installer files and allows you to optionally
install them
Expand All @@ -19,8 +19,6 @@ options:

`--list` Lists the available options

`--arch ARCH` Only include packages available on ARM

`--install` Install the packages on the list using pacman instead of just listing them

example:
Expand Down
15 changes: 4 additions & 11 deletions eos-packagelist/eos-packagelist
Original file line number Diff line number Diff line change
Expand Up @@ -95,22 +95,15 @@ if __name__ == '__main__':
)
parser.add_argument('profile', type=str, nargs='*', help='The name of the profile you want to see packages for')
parser.add_argument('--list', action="store_true", help='Lists the available options')
parser.add_argument('--arch', type=str, help='Only include packages available on ARM')
parser.add_argument('--install', action="store_true",
help='Install the packages on the list using pacman instead of just listing them')
args = parser.parse_args(args=None if sys.argv[1:] else ['--help'])

# Condition to choose ARM or x64_64
if (args.arch and args.arch != "x86_64") or (not args.arch and platform.machine() != "x86_64"):
url_netinstall = "https://raw.githubusercontent.com/endeavouros-arm/calamares-image/main/configs/calamares/modules" \
"/netinstall.yaml"
url_pkgchooser = "https://raw.githubusercontent.com/endeavouros-arm/calamares-image/main/configs/calamares/modules" \
"/packagechooser_ce.conf"
else:
url_netinstall = "https://raw.githubusercontent.com/endeavouros-team/calamares/calamares/data/eos/modules" \
"/netinstall.yaml"
url_pkgchooser = "https://raw.githubusercontent.com/endeavouros-team/calamares/calamares/data/eos/modules" \
"/packagechooser.conf"
url_netinstall = "https://raw.githubusercontent.com/endeavouros-team/calamares/calamares/data/eos/modules" \
"/netinstall.yaml"
url_pkgchooser = "https://raw.githubusercontent.com/endeavouros-team/calamares/calamares/data/eos/modules" \
"/packagechooser.conf"

# Get the data from the internet and parse it
netinstall_packages = []
Expand Down

0 comments on commit 12b8f84

Please sign in to comment.