-
Notifications
You must be signed in to change notification settings - Fork 18
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Added a dummy Kyber implementation and test scaffolding (#438)
* Added Kyber768 consistency test using a dummy implementation of Kyber. * Added Kyber768 KAT tests. * Update default_config.cmake * Build libcrux separately in CMakeLists.txt * Don't build libcrux by default.
- Loading branch information
Showing
13 changed files
with
1,123 additions
and
40 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
#ifndef __Libcrux_Kem_Kyber_Kyber768_H | ||
#define __Libcrux_Kem_Kyber_Kyber768_H | ||
|
||
#if defined(__cplusplus) | ||
extern "C" | ||
{ | ||
#endif | ||
|
||
#include <inttypes.h> | ||
|
||
#define KYBER768_SECRETKEYBYTES 2400 | ||
#define KYBER768_PUBLICKEYBYTES 1184 | ||
#define KYBER768_CIPHERTEXTBYTES 1088 | ||
#define KYBER768_SHAREDSECRETBYTES 32 | ||
|
||
int Libcrux_Kyber768_GenerateKeyPair(uint8_t* pk, | ||
uint8_t* sk, | ||
const uint8_t* randomness); | ||
int Libcrux_Kyber768_Encapsulate(uint8_t* ct, | ||
uint8_t* ss, | ||
const uint8_t* pk, | ||
const uint8_t* randomness); | ||
int Libcrux_Kyber768_Decapsulate(uint8_t* ss, | ||
const uint8_t* ct, | ||
const uint8_t* sk); | ||
|
||
#if defined(__cplusplus) | ||
} | ||
#endif | ||
|
||
#define __Libcrux_Kem_Kyber_Kyber768_H_DEFINED | ||
#endif |
Oops, something went wrong.