Skip to content

Commit

Permalink
github action for release
Browse files Browse the repository at this point in the history
  • Loading branch information
simjak committed Nov 9, 2023
1 parent 79834ad commit df195de
Show file tree
Hide file tree
Showing 3 changed files with 44 additions and 6 deletions.
42 changes: 42 additions & 0 deletions .github/workflows/release.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
name: Release

on:
push:
tags:
- '*'

jobs:
build:
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v2
- name: Set up Python
uses: actions/setup-python@v2
with:
python-version: '3.x'
- name: Install dependencies
run: |
python -m pip install --upgrade pip
pip install setuptools wheel twine
- name: Build and publish
env:
TWINE_USERNAME: __token__
TWINE_PASSWORD: ${{ secrets.PYPI_API_TOKEN }}
run: |
python setup.py sdist bdist_wheel
twine upload dist/*
release:
needs: build
runs-on: ubuntu-latest
steps:
- name: Create Release
id: create_release
uses: actions/create-release@v1
env:
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
with:
tag_name: ${{ github.ref }}
release_name: Release ${{ github.ref }}
draft: false
prerelease: false
3 changes: 2 additions & 1 deletion .gitignore
Original file line number Diff line number Diff line change
Expand Up @@ -4,10 +4,11 @@ __pycache__
.DS_Store
venv/
/.vscode
.vscode
**/__pycache__
**/*.py[cod]

# local env files
.env*.local
.env
mac.env
mac.env
5 changes: 0 additions & 5 deletions .vscode/settings.json

This file was deleted.

0 comments on commit df195de

Please sign in to comment.