Skip to content

Commit

Permalink
Merge pull request #289 from aurelio-labs/james/tiktoken-dep
Browse files Browse the repository at this point in the history
fix: tiktoken dep
  • Loading branch information
jamescalam authored May 16, 2024
2 parents 8fb8cd0 + 3a4a177 commit a8969d4
Show file tree
Hide file tree
Showing 3 changed files with 13 additions and 13 deletions.
2 changes: 1 addition & 1 deletion poetry.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

22 changes: 11 additions & 11 deletions pyproject.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[tool.poetry]
name = "semantic-router"
version = "0.0.42"
version = "0.0.43"
description = "Super fast semantic router for AI decision making"
authors = [
"James Briggs <[email protected]>",
Expand All @@ -17,23 +17,23 @@ packages = [{include = "semantic_router"}]
[tool.poetry.dependencies]
python = ">=3.9,<3.13"
pydantic = "^2.5.3"
openai = "^1.10.0"
cohere = "^5.00"
mistralai= {version = "^0.0.12", optional = true}
openai = ">=1.10.0,<2.0.0"
cohere = ">=5.00,<6.00"
mistralai= {version = ">=0.0.12,<0.1.0", optional = true}
numpy = "^1.25.2"
colorlog = "^6.8.0"
pyyaml = "^6.0.1"
pinecone-text = {version = "^0.7.1", optional = true}
pinecone-text = {version = ">=0.7.1,<0.8.0", optional = true}
fastembed = {version = "^0.2.4", optional = true, python = "<3.12"}
torch = {version = "^2.1.0", optional = true}
torch = {version = ">=2.1.0,<2.6.0", optional = true}
transformers = {version = "^4.36.2", optional = true}
llama-cpp-python = {version = "^0.2.28", optional = true}
colorama = "^0.4.6"
pinecone-client = {version="^3.0.0", optional = true}
regex = "^2023.12.25"
torchvision = { version = "^0.17.0", optional = true}
pillow = { version = "^10.2.0", optional = true}
tiktoken = "^0.6.0"
pinecone-client = {version=">=3.0.0,<4.0.0", optional = true}
regex = ">=2023.12.25"
torchvision = { version = ">=0.17.0,<0.18.0", optional = true}
pillow = { version = ">=10.2.0,<11.0.0", optional = true}
tiktoken = ">=0.6.0,<1.0.0"
matplotlib = { version = "^3.8.3", optional = true}
qdrant-client = {version = "^1.8.0", optional = true}
google-cloud-aiplatform = {version = "^1.45.0", optional = true}
Expand Down
2 changes: 1 addition & 1 deletion semantic_router/__init__.py
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,4 @@

__all__ = ["RouteLayer", "HybridRouteLayer", "Route", "LayerConfig"]

__version__ = "0.0.42"
__version__ = "0.0.43"

0 comments on commit a8969d4

Please sign in to comment.