Skip to content

Commit

Permalink
Merge pull request #474 from aurelio-labs/james/0.1.0.dev3
Browse files Browse the repository at this point in the history
chore: new dev release
  • Loading branch information
jamescalam authored Dec 1, 2024
2 parents a7846a5 + 97b15ba commit 26e29a2
Show file tree
Hide file tree
Showing 6 changed files with 24 additions and 26 deletions.
40 changes: 19 additions & 21 deletions docs/00-introduction.ipynb
Original file line number Diff line number Diff line change
Expand Up @@ -24,7 +24,7 @@
"id": "k1nRRAbYf3py"
},
"source": [
"The Semantic Router library can be used as a super fast route making layer on top of LLMs. That means rather than waiting on a slow agent to decide what to do, we can use the magic of semantic vector space to make routes. Cutting route making time down from seconds to milliseconds."
"The Semantic Router library can be used as a super fast decision making layer on top of LLMs. That means rather than waiting on a slow agent to decide what to do, we can use the magic of semantic vector space to make routes. Cutting route making time down from seconds to milliseconds."
]
},
{
Expand Down Expand Up @@ -53,7 +53,7 @@
},
"outputs": [],
"source": [
"!pip install -qU semantic-router"
"!pip install -qU \"semantic-router==0.1.0.dev3\""
]
},
{
Expand Down Expand Up @@ -167,7 +167,7 @@
"id": "lYuLO0l9f3p3"
},
"source": [
"Now we define the `RouteLayer`. When called, the route layer will consume text (a query) and output the category (`Route`) it belongs to — to initialize a `RouteLayer` we need our `encoder` model and a list of `routes`."
"Now we define the `Router`. When called, the router will consume text (a query) and output the category (`Route`) it belongs to — to initialize a `Router` we need our `encoder` model and a list of `routes`."
]
},
{
Expand All @@ -187,9 +187,9 @@
}
],
"source": [
"from semantic_router.layer import RouteLayer\n",
"from semantic_router.routers import SemanticRouter\n",
"\n",
"rl = RouteLayer(encoder=encoder, routes=routes)"
"sr = SemanticRouter(encoder=encoder, routes=routes)"
]
},
{
Expand Down Expand Up @@ -221,7 +221,7 @@
}
],
"source": [
"rl(\"don't you love politics?\")"
"sr(\"don't you love politics?\")"
]
},
{
Expand All @@ -244,7 +244,7 @@
}
],
"source": [
"rl(\"how's the weather today?\")"
"sr(\"how's the weather today?\")"
]
},
{
Expand Down Expand Up @@ -276,7 +276,7 @@
}
],
"source": [
"rl(\"I'm interested in learning about llama 2\")"
"sr(\"I'm interested in learning about llama 2\")"
]
},
{
Expand Down Expand Up @@ -309,7 +309,7 @@
}
],
"source": [
"rl.retrieve_multiple_routes(\"Hi! How are you doing in politics??\")"
"sr.retrieve_multiple_routes(\"Hi! How are you doing in politics??\")"
]
},
{
Expand All @@ -332,20 +332,21 @@
}
],
"source": [
"rl.retrieve_multiple_routes(\"I'm interested in learning about llama 2\")"
"sr.retrieve_multiple_routes(\"I'm interested in learning about llama 2\")"
]
},
{
"cell_type": "code",
"execution_count": null,
"metadata": {
"id": "QF_wATjYf3p4"
},
"outputs": [],
"source": []
"cell_type": "markdown",
"metadata": {},
"source": [
"---"
]
}
],
"metadata": {
"colab": {
"provenance": []
},
"kernelspec": {
"display_name": "decision-layer",
"language": "python",
Expand All @@ -362,11 +363,8 @@
"nbconvert_exporter": "python",
"pygments_lexer": "ipython3",
"version": "3.11.4"
},
"colab": {
"provenance": []
}
},
"nbformat": 4,
"nbformat_minor": 0
}
}
2 changes: 1 addition & 1 deletion docs/examples/hybrid-router.ipynb
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@
"metadata": {},
"outputs": [],
"source": [
"#!pip install -qU semantic-router==0.1.0.dev2"
"#!pip install -qU semantic-router==0.1.0.dev3"
]
},
{
Expand Down
2 changes: 1 addition & 1 deletion docs/indexes/pinecone-sync-routes.ipynb
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@
"metadata": {},
"outputs": [],
"source": [
"!pip install -qU \"semantic-router[pinecone]==0.1.0.dev2\""
"!pip install -qU \"semantic-router[pinecone]==0.1.0.dev3\""
]
},
{
Expand Down
2 changes: 1 addition & 1 deletion docs/source/conf.py
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@
project = "Semantic Router"
copyright = "2024, Aurelio AI"
author = "Aurelio AI"
release = "0.1.0.dev2"
release = "0.1.0.dev3"

# -- General configuration ---------------------------------------------------
# https://www.sphinx-doc.org/en/master/usage/configuration.html#general-configuration
Expand Down
2 changes: 1 addition & 1 deletion pyproject.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[tool.poetry]
name = "semantic-router"
version = "0.1.0.dev2"
version = "0.1.0.dev3"
description = "Super fast semantic router for AI decision making"
authors = ["Aurelio AI <[email protected]>"]
readme = "README.md"
Expand Down
2 changes: 1 addition & 1 deletion semantic_router/__init__.py
Original file line number Diff line number Diff line change
Expand Up @@ -3,4 +3,4 @@

__all__ = ["SemanticRouter", "HybridRouter", "Route", "RouterConfig"]

__version__ = "0.1.0.dev2"
__version__ = "0.1.0.dev3"

0 comments on commit 26e29a2

Please sign in to comment.