Skip to content

Commit

Permalink
linux.inc: split kernel-headers package into a separate include
Browse files Browse the repository at this point in the history
With Linux Mainline and Next, it's causing build issues:
|   INSTALL usr/include/video/ (3 files)
|   INSTALL usr/include/video/uvesafb.h/ (0 file)
| touch: cannot touch 'usr/include/video/uvesafb.h/.install': Not a directory
| scripts/Makefile.headersinst:116: recipe for target 'usr/include/video/uvesafb.h/.install' failed

Workaround the build failure by splitting the kernel-headers package into
a separate include. If kernel recipes need the kernel-headers, they can
include linux-headers.inc file.

Signed-off-by: Fathi Boudra <[email protected]>
  • Loading branch information
fboudra committed Jun 22, 2017
1 parent 0ac9623 commit 3a1b450
Show file tree
Hide file tree
Showing 2 changed files with 8 additions and 4 deletions.
8 changes: 8 additions & 0 deletions recipes-kernel/linux/linux-headers.inc
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
inherit kernel-arch

do_install_append() {
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
}

PACKAGES =+ "kernel-headers"
FILES_kernel-headers = "${exec_prefix}/src/linux*"
4 changes: 0 additions & 4 deletions recipes-kernel/linux/linux.inc
Original file line number Diff line number Diff line change
Expand Up @@ -201,7 +201,6 @@ do_configure_append() {
EXTRA_OEMAKE = "${PARALLEL_MAKE} "

do_install_append() {
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
oe_runmake firmware_install INSTALL_MOD_PATH=${D} ARCH=$ARCH
install -d ${D}/boot
make -C ${S} O=${B} ARCH=$ARCH dtbs || true
Expand All @@ -213,9 +212,6 @@ do_install_append() {
rm -f ${D}${KERNEL_SRC_PATH}/arch/*/vdso/vdso*.so
}

PACKAGES =+ "kernel-headers"
FILES_kernel-headers = "${exec_prefix}/src/linux*"

require recipes-kernel/linux/linux-dtb.inc

PACKAGES =+ "kernel-devicetree-overlays"
Expand Down

0 comments on commit 3a1b450

Please sign in to comment.