generated from nix-community/nur-packages-template
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
lix-game: actually support overrideScope
Didn't understand the docs correctly for makeScope/newScope, and somehow managed to never test the example I wrote in the README, I guess?
- Loading branch information
Showing
2 changed files
with
18 additions
and
20 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,19 +1,17 @@ | ||
{ newScope, maintainers, stdenvNoCC }: let | ||
{ lib, newScope, maintainers, stdenvNoCC }: let | ||
inherit (stdenvNoCC) isDarwin; | ||
callPackage = newScope self; | ||
self = { | ||
game = callPackage ./wrapper.nix {}; | ||
game-unwrapped = callPackage ./game.nix {}; | ||
assets = callPackage ./assets.nix {}; | ||
music = callPackage ./music.nix {}; | ||
server = callPackage ./server.nix {}; | ||
|
||
common = callPackage ./common.nix { inherit maintainers; }; | ||
highResTitleScreen = callPackage ./highResTitleScreen.nix {}; | ||
|
||
convertImagesToTrueColor = isDarwin; | ||
disableNativeImageLoader = callPackage ({convertImagesToTrueColor}: isDarwin && !convertImagesToTrueColor) {}; | ||
useHighResTitleScreen = false; | ||
includeMusic = true; | ||
}; | ||
in self | ||
in lib.makeScope newScope (self: let inherit (self) callPackage; in { | ||
game = callPackage ./wrapper.nix {}; | ||
game-unwrapped = callPackage ./game.nix {}; | ||
assets = callPackage ./assets.nix {}; | ||
music = callPackage ./music.nix {}; | ||
server = callPackage ./server.nix {}; | ||
|
||
common = callPackage ./common.nix { inherit maintainers; }; | ||
highResTitleScreen = callPackage ./highResTitleScreen.nix {}; | ||
|
||
convertImagesToTrueColor = isDarwin; | ||
disableNativeImageLoader = callPackage ({convertImagesToTrueColor}: isDarwin && !convertImagesToTrueColor) {}; | ||
useHighResTitleScreen = false; | ||
includeMusic = true; | ||
}) |