Skip to content
This repository has been archived by the owner on Oct 29, 2024. It is now read-only.

Commit

Permalink
Initial Commit for waybar-bluetooth_battery_parse
Browse files Browse the repository at this point in the history
  • Loading branch information
DataEraserC committed Oct 14, 2023
1 parent edb175d commit 9b143be
Show file tree
Hide file tree
Showing 3 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions default.nix
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,7 @@
pkgs.callPackage ./pkgs/wechat_dev_tools_appimage { };
wechat_dev_tools_deb = pkgs.callPackage ./pkgs/wechat_dev_tools_deb { };
qtscrcpy = pkgs.libsForQt5.callPackage ./pkgs/qtscrcpy { };
waybar-bluetooth_battery_parse = pkgs.callPackage ./pkgs/waybar-bluetooth_battery_parse { };
# some-qt5-package = pkgs.libsForQt5.callPackage ./pkgs/some-qt5-package { };
# ...
}
1 change: 1 addition & 0 deletions pkgs/waybar-bluetooth_battery_parse/default.nix
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
import ./waybar-bluetooth_battery_parse.nix
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# When you use pkgs.callPackage, parameters here will be filled with packages from Nixpkgs (if there's a match)
{ stdenv, fetchFromGitHub, cmake, gcc }@args:
let
src = fetchFromGitHub ({
owner = "Program-Learning";
repo = "waybar-bluetooth_battery_parse";
# Commit or tag, note that fetchFromGitHub cannot follow a branch!
rev = "96209641f510ac06f157f5493893ba55ef2a4dc7";
# Download git submodules, most packages don't need this
fetchSubmodules = false;
# Don't know how to calculate the SHA256 here? Comment it out and build the package
# Nix will raise an error and show the correct hash
sha256 = "sha256-hZ6gL5Iez2Ex8g10ROIGm7IYVxR2lLlu+/d+CbbjOEQ=";
});
in stdenv.mkDerivation rec {
# Specify package name and version
pname = "waybar-bluetooth_battery_parse";
version = "0.0.2";
src = src;
buildInputs = [ cmake ];

# Download source code from GitHub

# Parallel building, drastically speeds up packaging, enabled by default.
# You only want to turn this off for one of the rare packages that fails with this.
enableParallelBuilding = true;
# If you encounter some weird error when packaging CMake-based software, try enabling this
# This disables some automatic fixes applied to CMake-based software
dontFixCmake = true;

# Add CMake to the building environment, to generate Makefile with it
nativeBuildInputs = [ cmake ];

# Arguments to CMake that controls functionalities of liboqs
cmakeFlags = [ "-DCMAKE_INSTALL_PREFIX=$out" ];

# stdenv.mkDerivation automatically does the rest for you
}

0 comments on commit 9b143be

Please sign in to comment.