Skip to content
This repository has been archived by the owner on Oct 29, 2024. It is now read-only.

Commit

Permalink
Try
Browse files Browse the repository at this point in the history
  • Loading branch information
DataEraserC committed Oct 14, 2023
1 parent edb175d commit 12bb63b
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions pkgs/waybar-bluetooth_battery_parse/default.nix
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
import ./waybar-bluetooth_battery_parse.nix
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# When you use pkgs.callPackage, parameters here will be filled with packages from Nixpkgs (if there's a match)
{ lib
, stdenv
, fetchFromGitHub
, cmake
, ...
} @ args:

stdenv.mkDerivation rec {
# Specify package name and version
pname = "waybar-bluetooth_battery_parse";
version = "0.0.1";

# Download source code from GitHub
src = fetchFromGitHub ({
owner = "Program-Learning";
repo = "waybar-bluetooth_battery_parse";
# Commit or tag, note that fetchFromGitHub cannot follow a branch!
# rev = "0.7.1";
# Download git submodules, most packages don't need this
fetchSubmodules = false;
# Don't know how to calculate the SHA256 here? Comment it out and build the package
# Nix will raise an error and show the correct hash
sha256 = "sha256-m20M4+3zsH40hTpMJG9cyIjXp0xcCUBS+cCiRVLXFqM=";
});

# Parallel building, drastically speeds up packaging, enabled by default.
# You only want to turn this off for one of the rare packages that fails with this.
enableParallelBuilding = true;
# If you encounter some weird error when packaging CMake-based software, try enabling this
# This disables some automatic fixes applied to CMake-based software
dontFixCmake = true;

# Add CMake to the building environment, to generate Makefile with it
nativeBuildInputs = [ cmake ];

# Arguments to CMake that controls functionalities of liboqs
cmakeFlags = [
"-DBUILD_SHARED_LIBS=ON"
];

# stdenv.mkDerivation automatically does the rest for you
}

0 comments on commit 12bb63b

Please sign in to comment.