-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathPalindrome.java
49 lines (43 loc) · 1.59 KB
/
Palindrome.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
/* Check Palindrome
Given a string, determine if it is a palindrome, considering only alphanumeric characters.
Palindrome
A palindrome is a word, number, phrase, or other sequences of characters which read the same backwards and forwards.
Example:
If the input string happens to be, "malayalam" then as we see that this word can be read the same as forward and backwards, it is said to be a valid palindrome.
The expected output for this example will print, 'true'.
From that being said, you are required to return a boolean value from the function that has been asked to implement.
Input Format:
The first and only line of input contains a string without any leading and trailing spaces. All the characters in the string would be in lower case.
Output Format:
The only line of output prints either 'true' or 'false'.
Note:
You are not required to print anything. It has already been taken care of.
Constraints:
0 <= N <= 10^6
Where N is the length of the input string.
Time Limit: 1 second
Sample Input 1 :
abcdcba
Sample Output 1 :
true
*/
import java.lang.System;
import java.util.*;
public class Palindrome {
public static void main(String[] args) {
try (Scanner sc = new Scanner(System.in)) {
String s = sc.nextLine();
int i = 0, j = s.length() - 1;
boolean isPalindrome = true;
while (i < j) {
if (s.charAt(i) != s.charAt(j)) {
isPalindrome = false;
break;
}
i++;
j--;
}
System.out.println(isPalindrome);
}
}
}