Skip to content

Commit

Permalink
vkmark: add package
Browse files Browse the repository at this point in the history
Signed-off-by: Daniel Golle <[email protected]>
  • Loading branch information
dangowrt committed Dec 2, 2024
1 parent 90db1a8 commit 48ccfe3
Showing 1 changed file with 49 additions and 0 deletions.
49 changes: 49 additions & 0 deletions libs/vkmark/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=vkmark
PKG_RELEASE:=1

PKG_SOURCE_PROTO:=git
PKG_SOURCE_DATE:=2023-04-12
PKG_SOURCE_VERSION:=ab6e6f34077722d5ae33f6bd40b18ef9c0e99a15
PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME).git
PKG_MIRROR_HASH:=a0f268a88239d60650bc6ab2fa57cb99b75e28d4a11a07708c7dced5deea8fcb

PKG_MAINTAINER:=Daniel Golle <[email protected]>
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING-LGPL2.1

PKG_BUILD_FLAGS:=gc-sections lto
PKG_BUILD_DEPENDS:=glm

include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/meson.mk

define Package/vkmark
SECTION:=utils
CATEGORY:=Utilities
SUBMENU:=Video
TITLE:=Vulkan benchmark
URL:=https://github.com/vkmark/vkmark
DEPENDS:=+libstdcpp +libassimp +libdrm +libmesa +libwayland +vulkan-loader
endef

define Package/vkmark/description
vkmark is an extensible Vulkan benchmarking suite with targeted, configurable scenes.
endef

MESON_ARGS += \
-Dxcb=false \
-Dwayland=true \
-Dkms=true

define Package/vkmark/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/lib/vkmark
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/vkmark/*.so $(1)/usr/lib/vkmark
$(INSTALL_DIR) $(1)/usr/share/vkmark
$(CP) $(PKG_INSTALL_DIR)/usr/share/vkmark/* $(1)/usr/share/vkmark
endef

$(eval $(call BuildPackage,vkmark))

0 comments on commit 48ccfe3

Please sign in to comment.