+ Set the timeout value (in seconds) for checking a mirror.
+ Default: 30.
+
+ --use-local-mirrorlist
+ For testing purposes.
+ Uses information in local /etc/pacman.d/endeavouros-mirrorlist as the base for ranking.
+
+ --verbose
+ Show more detailed output.
+
+Advanced options:
+ --list-only
+ Save only the mirrorlist without the ranking statistics.
+
+ --mirror-add
+ Temporarily add a mirror URL for ranking (for testing purposes only).
+```
+## Configuration
+
+### Configurable variables in file /etc/eos-rankmirrors.conf
+
+For detailed info, see the comments in file `/etc/eos-rankmirrors.conf`.
+
+Variable name | Default value | Description
+:---- | :---- | :----
+EOS_AUTO_MIRROR_RANKING | no | Write the ranking result to file `/etc/endeavouros-mirrorlist`
or `/etc/endeavouros-mirrorlist.pacnew`.
+EOS_AUTORANK_TIMEOUT | 30 | Timeout in seconds for each mirror to respond.
+ALWAYS_FIRST_EOS_MIRRORS | `''` (an empty string) | A list of mirrors to set as first in the ranking result.
+EOS_IGNORED_MIRRORS | () | Array of mirrors to ignore when ranking.
+EOS_RANKMIRRORS_EXIT_CODE_VERBOSITY | show | How much information will be shown a mirror fails to rank.
Supported values: `all`, `code`, `show`, `none`.
See `/etc/eos-rankmirrors.conf` for more details.
+
+
+Example:
+```
+# Partial contents of file /etc/eos-rankmirrors.conf.
+# Note: use bash syntax.
+
+EOS_AUTO_MIRROR_RANKING=no
+EOS_AUTORANK_TIMEOUT=10
+ALWAYS_FIRST_EOS_MIRRORS='tsinghua|pizza|funami'
+EOS_IGNORED_MIRRORS=(belnet accum jingk)
+EOS_RANKMIRRORS_EXIT_CODE_VERBOSITY=none
+```
diff --git a/eos-apps-info/man/eos-update-notifier-configure/eos-update-notifier-configure.md b/eos-apps-info/man/eos-update-notifier-configure/eos-update-notifier-configure.md
new file mode 100644
index 00000000..739a5684
--- /dev/null
+++ b/eos-apps-info/man/eos-update-notifier-configure/eos-update-notifier-configure.md
@@ -0,0 +1,21 @@
+# eos-update-notifier-configure
+
+Manages and configures certain features of `eos-update-notifier` with a small GUI.
+
+![](eos-update-notifier-configure.png)
+
+## Synopsis
+```
+eos-update-notifier-configure
+```
+## Tips
+Variable `EOS_SUDO_EDITORS` in configuration file
+```
+/etc/eos-script-lib-yad.conf
+```
+determines which editor will be used when editing the configuration file
+```
+/etc/eos-update-notifier.conf
+```
+after clicking the **Edit config** button above.
+Note that environment variables `SUDO_EDITOR`, `VISUAL`, or `EDITOR` can be used if `EOS_SUDO_EDITORS` is not set.
diff --git a/eos-apps-info/man/eos-update-notifier-configure/eos-update-notifier-configure.png b/eos-apps-info/man/eos-update-notifier-configure/eos-update-notifier-configure.png
new file mode 100644
index 00000000..936ae608
Binary files /dev/null and b/eos-apps-info/man/eos-update-notifier-configure/eos-update-notifier-configure.png differ
diff --git a/eos-apps-info/man/eos-update-notifier/eos-update-notifier.md b/eos-apps-info/man/eos-update-notifier/eos-update-notifier.md
new file mode 100644
index 00000000..4bf9fd64
--- /dev/null
+++ b/eos-apps-info/man/eos-update-notifier/eos-update-notifier.md
@@ -0,0 +1,30 @@
+# eos-update-notifier
+
+Checks the availability of package updates (EndeavourOS, Arch, and AUR), and offers to perform the actual update.
+
+## Synopsis
+```
+eos-update-notifier [options]
+```
+## Options
+```
+-init Initialize the eos-update-notifier systemd service for
+ the current user.
+-init-force Same as -init, but may overwrite existing user service files.
+-conf Configure the schedule of checking for the updates.
+-show-timer Show the status of the systemd timer.
+-iw=X Initial sleep time. Value syntax from 'sleep' program.
+ Default: 5s.
+-nw=X Max time (seconds) to show the "No updates available" window.
+ Default: 10.
+-q Be quieter with dialogs.
+--changelog Show the changelog of this package.
+```
+
+## Tips
+
+Configuration file: `/etc/eos-update-notifier.conf`.
+
+## See also
+
+[eos-update-notifier-configure](/etc/eos-apps-info/pageinfo/eos-update-notifier-configure/eos-update-notifier-configure.html)
diff --git a/eos-apps-info/man/eos-welcome b/eos-apps-info/man/eos-welcome
new file mode 120000
index 00000000..b6cbc2d1
--- /dev/null
+++ b/eos-apps-info/man/eos-welcome
@@ -0,0 +1 @@
+welcome
\ No newline at end of file
diff --git a/eos-apps-info/man/mirrorlist-rank-info/mirrorlist-rank-info.md b/eos-apps-info/man/mirrorlist-rank-info/mirrorlist-rank-info.md
new file mode 100644
index 00000000..c90daf6a
--- /dev/null
+++ b/eos-apps-info/man/mirrorlist-rank-info/mirrorlist-rank-info.md
@@ -0,0 +1,18 @@
+# mirrorlist-rank-info
+
+`mirrorlist-rank-info` shows up-to-date ranking information about the mirrors in file `/etc/pacman.d/mirrorlist`.
+
+![](mirrorlist-rank-info.png)
+
+## Synopsis
+```
+mirrorlist-rank-info [options]
+```
+## Options
+
+```
+ --age Sorting precedence: 'age' over 'rate'
+ --rate Sorting precedence: 'rate' over 'age'
+ --help
+ -h Show this help
+```
diff --git a/eos-apps-info/man/mirrorlist-rank-info/mirrorlist-rank-info.png b/eos-apps-info/man/mirrorlist-rank-info/mirrorlist-rank-info.png
new file mode 100644
index 00000000..aacb0c5f
Binary files /dev/null and b/eos-apps-info/man/mirrorlist-rank-info/mirrorlist-rank-info.png differ
diff --git a/eos-apps-info/man/pahis/README.md b/eos-apps-info/man/pahis/README.md
new file mode 100644
index 00000000..89edd795
--- /dev/null
+++ b/eos-apps-info/man/pahis/README.md
@@ -0,0 +1,34 @@
+# pahis
+Show pacman history for all or selected packages.
+
+## Usage
+Run command
+
+pahis --help
+
+about how to use it.
+Note: you can use bash completion (tab) to complete a partial words and options!
+
+Examples:
+
+pahis --upgraded # shows upgrades of all packages
+pahis --upgraded firefox # shows when firefox was upgraded
+pahis geany # shows all operations on geany
+pahis --removed # shows removals of packages
+pahis -installed # shows installs of packages
+pahis --Running # shows pacman commands used
+
+
+## Screenshots after commands
+
+pahis
+
+![pahis](pahis1.png)
+
+pahis --upgraded
+
+![](pahis2.png)
+
+pahis --upgraded firefox
+
+![](pahis3.png)
diff --git a/eos-apps-info/man/pahis/pahis1.png b/eos-apps-info/man/pahis/pahis1.png
new file mode 100644
index 00000000..94e961bc
Binary files /dev/null and b/eos-apps-info/man/pahis/pahis1.png differ
diff --git a/eos-apps-info/man/pahis/pahis2.png b/eos-apps-info/man/pahis/pahis2.png
new file mode 100644
index 00000000..65eea861
Binary files /dev/null and b/eos-apps-info/man/pahis/pahis2.png differ
diff --git a/eos-apps-info/man/pahis/pahis3.png b/eos-apps-info/man/pahis/pahis3.png
new file mode 100644
index 00000000..afd071be
Binary files /dev/null and b/eos-apps-info/man/pahis/pahis3.png differ
diff --git a/eos-apps-info/man/reflector-simple/README.md b/eos-apps-info/man/reflector-simple/README.md
new file mode 100644
index 00000000..bda6f325
--- /dev/null
+++ b/eos-apps-info/man/reflector-simple/README.md
@@ -0,0 +1,49 @@
+# reflector-simple
+
+Simple GUI for the `reflector` command.
+Screenshot:
+
+![](reflector-simple.png)
+
+## Notes about configuration of reflector-simple
+
+- configuration file `/etc/reflector-simple.conf` is supported
+- if `/etc/reflector-simple.conf` exists, the GUI uses it by default
+- configuration file can contain options supported by the `reflector` command. Use command `reflector -h` for more info
+
+### Additional old compatibility notes
+- for backwards compatibility, configuration file `/etc/reflector-auto.conf` is still supported, but will no more be supported after year 2020.
+- if file `/etc/reflector-simple.conf` exists, then `/etc/reflector-auto.conf` is not used
+
+## Operational changes
+
+Version 1.15.2-1 changed `reflector-simple` by changing the setting **Max number of mirrors** (which uses reflector's --number option) to **Max number of freshed mirrors** (uses reflector's --latest option).
+
+The old behaviour can be achieved by using an environment variable `REFLECTOR_SIMPLE_PREFER_NUMBER` with value "yes", e.g.
+```
+REFLECTOR_SIMPLE_PREFER_NUMBER=yes reflector-simple
+```
+
+Version 1.16.1-1 changed the method of finding the country code of a user. Now user can change the value of variable `REFLECTOR_SIMPLE_COUNTRY_METHOD` in file `/etc/reflector-simple-tool.conf` and see what's the best (=fastest) method (number from 0 to 5) of fetching the country code. This may have a great effect on how quickly `reflector-simple` shows its first window when started.
+
+## Tips
+
+- import reflector options from another configuration file with a normal `reflector` syntax: `@/path/to/another/config.conf`
+- to exclude a country from ranking, use option `--country-exclude` (this option is not found in `reflector`)
+
+### Example configuration file
+```
+# A part of file /etc/reflector-simple.conf:
+
+# ...
+
+@/etc/reflector_excludes.conf
+-c DE,FR,"United Kingdom"
+--country-exclude LU
+
+# ...
+```
+
+## See also
+
+[reflector(1)](https://man.archlinux.org/man/reflector.1)
diff --git a/eos-apps-info/man/reflector-simple/reflector-simple.png b/eos-apps-info/man/reflector-simple/reflector-simple.png
new file mode 100644
index 00000000..3163e0f1
Binary files /dev/null and b/eos-apps-info/man/reflector-simple/reflector-simple.png differ
diff --git a/eos-apps-info/man/welcome/welcome-man.png b/eos-apps-info/man/welcome/welcome-man.png
new file mode 100644
index 00000000..1d44c4e4
Binary files /dev/null and b/eos-apps-info/man/welcome/welcome-man.png differ
diff --git a/eos-apps-info/man/welcome/welcome.md b/eos-apps-info/man/welcome/welcome.md
new file mode 100644
index 00000000..c8b47085
--- /dev/null
+++ b/eos-apps-info/man/welcome/welcome.md
@@ -0,0 +1,158 @@
+# welcome (also: eos-welcome)
+
+Welcome is an application that helps users by providing
+- tools for system management and customization
+- links for additional information
+
+and more.
+
+Welcome has two main uses:
+- helps in the install phase
+- helps in the system usage phase
+
+
+
+![](welcome-man.png)
+
+## Synopsis
+
+eos-welcome [options]
+
+## Options
+```
+--enable | -f Enable this Welcome app.
+--disable Disable this Welcome app.
+--once | -1 Allow to run Welcome even if disabled.
+--lang=X Use language X on the user interface. Default for X: 'en'
+--version Show the version of this app.
+--startdelay=X Wait before actually starting this app.
+ X value syntax is the same as in the 'sleep' command.
+--changelog Show the changelog of this package.
+
+```
+
+## Description
+
+### Enabling or disabling Welcome
+
+To have Welcome app started when you log in, make sure
+- Welcome app is selected in the Autostart feature of the DE
+ or
+- `Hidden=false` is set in file `/etc/xdg/autostart/welcome.desktop`
+
+On DEs that do not work well with system's *Autostart* feature, you may also disable the Welcome app from the app itself
+- with the `--disable` option
+- with a button in the app (some DEs only)
+
+To re-enable the app, click the Welcome app icon, or use the terminal command
+```
+eos-welcome --enable
+```
+
+To run Welcome *once* even if it is already disabled, use option `--once`:
+```
+eos-welcome --once
+```
+Welcome will stay disabled after using option `--once`.
+
+
+Note: check also settings in the configuration file `~/.config/EOS-greeter.conf`.
+
+### Personalizing Welcome
+
+User may add own buttons into the Welcome app. The buttons will appear under the **Personal Commands** tab.
+
+### Language support
+
+Option `--lang=X` currently supports a small set of languages.
+The X should consist of two (or more) letters (like 'en' for English or 'pt_BR' for Brazilian Portuguese).
+
+See the supported languages (the X) e.g. by terminal command
+```
+ls -1 /usr/share/endeavouros/scripts/translation-*.bash | \
+ sed 's|.*/translation-\([a-zA-Z_]*\)\.bash|\1|'
+```
+If option `--lang` is not given, the language value is extracted from
+the first letters of the environment variable LANG.
+If the extracted value is not supported by Welcome, English will be used.
+
+## Tips
+
+### Software news
+
+Welcome app window includes a button **Software News** on the lower left corner.
+It contains useful and important news for the user about the EndeavourOS software, e.g. manual interventions or important code changes.
+
+Make sure you click that button regularly!
+
+### Critical info area
+
+Welcome has an info area for critical or very important news near the upper edge of the window.
This will used for the uttermost important messages that affect all or most EndeavourOS users.
When this area contains text, it is a very good idea to read it!
+
+### Add favorite packages at install time
+
+To customize the *online* mode install phase, you can directly modify file `$HOME/user_pkglist.txt` and add package names to that file. Note that only Arch and EndeavourOS packages are supported, but not AUR packages.
+
+### Add commands at install time (*Advanced*)
+
+To customize the *online* mode install phase, you can directly modify file
+```
+/home/liveuser/user_commands.bash
+```
+and add almost any commands to that file. See more instructions in this file.
+
+Examples of things you can do with the commands in `user_commands.bash`:
+- install or remove packages
+- enable or disable systemd services
+- customize new user's personal files at $HOME
+- and more!
+
+Here's an example code for `user_commands.bash`. It will be called with the bash interpreter, so it must have bash syntax:
+```
+#!/bin/bash
+
+pacman -R --noconfirm xed # uninstall packages
+pacman -S --noconfirm --needed geany gufw # install packages
+systemctl enable ufw # enable a systemd service
+
+user=$(cat /tmp/new_username.txt) # get the new username!
+home=/home/$user # get the $HOME folder path
+if [ "$user" != "" ] ; then
+ cat <> $home/.bashrc # add more configuration to your ~/.bashrc
+
+alias pacdiff=eos-pacdiff
+alias df='df -hT'
+
+EOF
+chown $user:$user $home/.bashrc # make sure ~/.bashrc has the right owner
+fi
+```
+Yet another tip: download *your* `user_commands.bash` from your website! For example:
+```
+$ pwd
+/home/liveuser
+$ wget -O user_commands.bash https:///user_commands.bash
+```
+
+Examples of commands that *cannot* be used here:
+- yay
+- makepkg
+
+
+## Examples
+```
+eos-welcome --lang=en # use English instead of the local language
+eos-welcome --disable # disable Welcome from starting automatically
+eos-welcome --enable # re-enable Welcome after disabling it
+
+# Adding packages at install. Close Welcome app first, then commmand:
+
+cat <> ~/user_pkglist.txt
+ gufw
+ emacs
+EOF
+eos-welcome &
+```
+## See also
+
+https://discovery.endeavouros.com/endeavouros-tools/welcome